This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 176724 - kudzu - segmentation fault during a boot time
kudzu - segmentation fault during a boot time
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 176490 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-30 17:43 EST by Damian Wrobel
Modified: 2014-03-16 22:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.2.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-01 02:03:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kudzu coredump (1.15 MB, application/octet-stream)
2005-12-30 17:43 EST, Damian Wrobel
no flags Details
/etc/sysconfig/hwconf (5.83 KB, application/octet-stream)
2005-12-30 17:44 EST, Damian Wrobel
no flags Details
/etc/sysconfig/kudzu (168 bytes, text/plain)
2005-12-30 17:45 EST, Damian Wrobel
no flags Details
lspci output (9.50 KB, text/plain)
2005-12-30 17:47 EST, Damian Wrobel
no flags Details

  None (edit)
Description Damian Wrobel 2005-12-30 17:43:20 EST
Description of problem:
kudzu is failing to run with the segmentation fault during a boot time.

Version-Release number of selected component (if applicable):
1.2.16-1

How reproducible:
always

Steps to Reproduce:
1. run kudzu without any options

callstack:

#0  0x4c31b466 in free () from /lib/libc.so.6
#1  0x0804e03f in freeDevice (dev=0x80d1150) at kudzu.c:195
#2  0x08051df6 in pciFreeDevice (dev=0x80d1150) at pci.c:62
#3  0x0805283a in pciProbe (probeClass=CLASS_UNSPEC, probeFlags=Variable
"probeFlags" is not available.
) at pci.c:528
#4  0x080506e6 in probeDevices (probeClass=CLASS_UNSPEC, probeBus=-9,
    probeFlags=1) at kudzu.c:808
#5  0x0804d394 in main (argc=Cannot access memory at address 0x4
) at hwconf.c:1010
#6  0x4c2ce59e in __libc_start_main () from /lib/libc.so.6
#7  0x0804a4c1 in _start ()


valgrind says:

Invalid free() / delete / delete[]
==2516==    at 0x1B90215D: free (vg_replace_malloc.c:235)
==2516==    by 0x804E03E: freeDevice (kudzu.c:195)
==2516==    by 0x8051DF5: ??? (pci.c:62)
==2516==    by 0x8052839: ??? (pci.c:528)
==2516==    by 0x80506E5: ??? (kudzu.c:808)
==2516==    by 0x804D393: ??? (hwconf.c:1010)
==2516==    by 0x4C2CE59D: __libc_start_main (in /lib/libc-2.3.90.so)
==2516==    by 0x804A4C0: (within /sbin/kudzu)
==2516==  Address 0x8068FC0 is not stack'd, malloc'd or (recently) free'd
Comment 1 Damian Wrobel 2005-12-30 17:43:21 EST
Created attachment 122647 [details]
kudzu coredump
Comment 2 Damian Wrobel 2005-12-30 17:44:40 EST
Created attachment 122648 [details]
/etc/sysconfig/hwconf
Comment 3 Damian Wrobel 2005-12-30 17:45:19 EST
Created attachment 122649 [details]
/etc/sysconfig/kudzu
Comment 4 Damian Wrobel 2005-12-30 17:47:27 EST
Created attachment 122651 [details]
lspci output
Comment 5 Bill Nottingham 2006-01-01 01:47:50 EST
01:05.0 RAID bus controller: <pci_lookup_name: buffer too small> (rev 13)

Niiiiiiice. If you edit the 1283:8212 entry in /usr/share/hwdata/pci.ids to be
shorter, does it stop segfaulting?
Comment 6 Bill Nottingham 2006-01-01 02:02:49 EST
*** Bug 176490 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2006-01-01 02:03:36 EST
Fixed in 1.2.17-1.
Comment 8 Damian Wrobel 2006-01-01 16:33:23 EST
(In reply to comment #5)
> Niiiiiiice. If you edit the 1283:8212 entry in /usr/share/hwdata/pci.ids to be
> shorter, does it stop segfaulting?
Yes it does.

Note You need to log in before you can comment on or make changes to this bug.