Bug 176730 - update-desktop-database is using uninitialised memory.
update-desktop-database is using uninitialised memory.
Status: CLOSED DUPLICATE of bug 178591
Product: Fedora
Classification: Fedora
Component: desktop-file-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-30 22:01 EST by Dave Jones
Modified: 2015-01-04 17:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-05 00:01:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2005-12-30 22:01:56 EST
I found this because I run with MALLOC_PERTURB_ set to something random.
it happens when I install certain packages.

Core was generated by `update-desktop-database -q'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/lib64/libglib-2.0.so.0...done.
Loaded symbols for /usr/lib64/libglib-2.0.so.0
Reading symbols from /usr/lib64/libpopt.so.0...done.
Loaded symbols for /usr/lib64/libpopt.so.0
Reading symbols from /lib64/libc.so.6...done.
Loaded symbols for /lib64/libc.so.6
Reading symbols from /lib64/ld-linux-x86-64.so.2...done.
Loaded symbols for /lib64/ld-linux-x86-64.so.2
#0  0x00000031a868dcc6 in opendir () from /lib64/libc.so.6
(gdb) bt
#0  0x00000031a868dcc6 in opendir () from /lib64/libc.so.6
#1  0x00000031a96183f9 in g_dir_open () from /usr/lib64/libglib-2.0.so.0
#2  0x00000000004024df in process_desktop_files (desktop_dir=0x9696969696969696
<Address 0x9696969696969696 out of bounds>,
    prefix=0x406730 "", error=0x7fffffb83870) at update-desktop-database.c:238
#3  0x0000000000402b0d in main (argc=2, argv=Variable "argv" is not available.
) at update-desktop-database.c:419
#4  0x00000031a861cc44 in __libc_start_main () from /lib64/libc.so.6
#5  0x0000000000402429 in _start ()
#6  0x00007fffffb83988 in ?? ()
#7  0x0000000000000000 in ?? ()

Note the parameters to process_desktop_files.
Comment 1 Matthias Clasen 2006-02-05 00:01:18 EST

*** This bug has been marked as a duplicate of 178591 ***

Note You need to log in before you can comment on or make changes to this bug.