This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 176766 - Ugly header on PDF documents from DocBook
Ugly header on PDF documents from DocBook
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: docbook-style-xsl (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 307001
  Show dependency treegraph
 
Reported: 2006-01-01 20:47 EST by W. Michael Petullo
Modified: 2009-06-23 11:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.69.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-23 11:06:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch so that pagesetup uses percentages instead of proportional-column-width (3.05 KB, patch)
2006-01-01 20:50 EST, W. Michael Petullo
no flags Details | Diff

  None (edit)
Description W. Michael Petullo 2006-01-01 20:47:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.12) Gecko/20051215 Epiphany/1.9.3.1

Description of problem:
The passivetex package does not understand the proportional-column-width keyword.  This keyword is used by docbook-style-xsl-1.69.1-1.1's pagesetup.xsl to define the document header when transforming from DocBook to FO.  See also http://www.mail-archive.com/docbook-apps@lists.oasis-open.org/msg07703.html.

Version-Release number of selected component (if applicable):
passivetex-1.25-5.1

How reproducible:
Always

Steps to Reproduce:
1.  Create a DocBook book document (foo.xml.)

2.  Create an XSL wrapper (foo.xsl) that sets <xsl:param name="header.column.widths" select="'1 2 1'"></xsl:param>.

3.  xmlto -x foo.xsl pdf foo.xml.

Actual Results:  The xmlto program says:

[....]
! Emergency stop.
<to be read again>
                   p
l.206 />
        </fo:block></fo:block></fo:flow></fo:page-sequence><fo:page-sequence...

!  ==> Fatal error occurred, the output PDF file is not finished!
Transcript written on tmp.log.
make: *** [golem.pdf] Error 1

Additional info:
Comment 1 W. Michael Petullo 2006-01-01 20:50:15 EST
Created attachment 122679 [details]
Patch so that pagesetup uses percentages instead of proportional-column-width
Comment 2 W. Michael Petullo 2006-01-01 20:52:54 EST
The patch in comment #1 is against the FO pagesetup.xsl included in
docbook-style-xsl, not passivetex.

If header.column.widths is left at the default of "1 1 1" then the portion of
the header reserved for chapter names is too narrow.  This results in a header
that looks like this:

   Hardware and
  Operating System
  Installation

instead of:

   Hardware and Operating System Installation
Comment 3 Tim Waugh 2006-01-03 08:43:42 EST
Thanks.  Fixed in CVS.
Comment 4 Fedora Update System 2006-01-20 11:56:37 EST
From User-Agent: XML-RPC

docbook-style-xsl-1.68.1-1.1 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Fedora Update System 2006-02-07 11:00:55 EST
From User-Agent: XML-RPC

docbook-style-xsl-1.68.1-1.1 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 W. Michael Petullo 2006-06-25 12:43:43 EDT
Confirmed fixed.
Comment 7 Ondrej Vasik 2007-12-03 08:56:43 EST
Because of 307001 it will be necessary to change the patch. I'll make the change
dependent on passivetex.extensions variable from param.xsl as the fix is
necessary only for passivetex and is breaking things for fop. 
Comment 8 W. Michael Petullo 2009-06-08 22:23:15 EDT
This is an issue again in docbook-style-xsl-1.74.0-5.fc10.noarch. Was the patch pulled back out? The solution proposed in Comment #1 once again fixes this for me.
Comment 9 Ondrej Vasik 2009-06-09 04:15:26 EDT
Please read comment #7 ... it was not removed, but made dependent on passivetex.extensions parameter (in fact it's passivetex issue, but as passivetex is very difficult to fix and it's upstream is dead, it's easier to workaround it in docbook xsl stylesheets - unfortunately upstream of docbook stylesheets is very reluctant to add such workarounds for dead passivetex). So to make it work, you have to activate passivetex.extensions parameter in /usr/share/sgml/docbook/xsl-stylesheets/fo/param.xsl - and it will work correctly again. Activating it by default (or making that change/patch not dependent on passivetex-extensions parameter) will break fop functionality. 

Could you please confirm that with correctly set passivetex.extensions parameter is the problem still fixed? 

Note: this is not the only workaround for passivetex, there are in fact more such things - e.g. indexes, list-item-body, so activating this boolean for passivetex-only (no fop, no dblatex, no xmlroff) text processing is always good idea.
Comment 10 Bug Zapper 2009-06-09 05:08:41 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Ondrej Vasik 2009-06-23 11:06:12 EDT
Closing WORKSFORME - as it works for me with passivetex.extensions enabled - and that's expected behaviour - to prevent breakage of fop functionality.

Note You need to log in before you can comment on or make changes to this bug.