Bug 176770 - Compile warnings when system-config-display is started up
Compile warnings when system-config-display is started up
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-02 03:11 EST by Reuben Farrelly
Modified: 2014-06-18 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-19 04:49:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2006-01-02 03:11:22 EST
If system-config-display is started from a terminal window, these warnings are
displayed:

[root@typhoon ~]# system-config-display
/usr/share/system-config-display/xconf.py:32: DeprecationWarning: rhpl.monitor
is deprecated; import rhpxl.monitor instead.
  import rhpl.monitor
/usr/share/system-config-display/xconf.py:33: DeprecationWarning: rhpl.videocard
is deprecated; import rhpxl.videocard instead.
  import rhpl.videocard
/usr/share/system-config-display/xconf.py:35: DeprecationWarning: rhpl.mouse is
deprecated; import rhpxl.mouse instead.
  import rhpl.mouse
/usr/share/system-config-display/xconf.py:37: DeprecationWarning: rhpl.xhwstate
is deprecated; import rhpxl.xhwstate instead.
  from rhpl.xhwstate import *

I suspect the repair is trivial, but these should really be cleaned up before
FC5 release.............

This is with a Rawhide tree as of 02 Jan 06.
Comment 1 petrosyan 2006-01-16 23:52:11 EST
this bug has been fixed in system-config-display-1.0.35-1
Comment 2 Reuben Farrelly 2006-01-19 04:49:39 EST
Yep all seems to be OK now.  Thanks :)

Note You need to log in before you can comment on or make changes to this bug.