Bug 176772 - CTRL-ALT-F[1-6] is disabled when gdm is running
Summary: CTRL-ALT-F[1-6] is disabled when gdm is running
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kbd   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-02 08:22 UTC by Per Nystrom
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-07 01:35:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg config file (2.71 KB, text/plain)
2006-01-04 00:41 UTC, Per Nystrom
no flags Details
/etc/sysconfig/keyboard (36 bytes, text/plain)
2006-01-04 00:42 UTC, Per Nystrom
no flags Details

Description Per Nystrom 2006-01-02 08:22:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Something happened between version kbd-1.12-10 and kbd-1.12-10.fc4.1 that causes the CTRL-ALT-[1-6] keys to have no effect while gdm is running (typically in runlevel 5, though I can duplicate the problem by starting it manually from the command line).

Version-Release number of selected component (if applicable):
kbd-1.12-10.fc4.1

How reproducible:
Always

Steps to Reproduce:
1. Update to kbd-1.12-10.fc4.1
2. Boot to runlevel 5
3. Try to use CTRL-ALT-F[1-6] to get a text console
  

Actual Results:  No change.  X console is still active.

Note:  I see other bugs floating around where the CTRL-ALT-F[1-6] keys cause a blank screen.  This is not the same behavior I'm seeing, and I was able to fix it by reverting to kbd-1.12-10.

Expected Results:  Text console should appear.

Additional info:

$ lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV35 [GeForce FX 5900] (rev a1)
02:03.0 Ethernet controller: Linksys NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)
02:04.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

Comment 1 Miloslav Trmač 2006-01-03 18:30:44 UTC
I can't reproduce this.  I have tested kbd-1.12-10.fc4.1 and kbd-1.12-12,
with or without rhgb, "us" keytable, XkbLayout "us".

Please attach your /etc/sysconfig/keyboard and /etc/X11/xorg.conf.  If you are
using the NVidia binary module, please try also using "nv".

Comment 2 Per Nystrom 2006-01-04 00:39:50 UTC
I have had rhgb disabled since install.

I tried it with both nv and nvidia drivers: same results.  The only other
difference is that I'm using a dvorak keyboard map.  I'm attaching the requested
files.


Comment 3 Per Nystrom 2006-01-04 00:41:12 UTC
Created attachment 122736 [details]
xorg config file

Comment 4 Per Nystrom 2006-01-04 00:42:27 UTC
Created attachment 122737 [details]
/etc/sysconfig/keyboard

Comment 5 Miloslav Trmač 2006-01-07 01:35:56 UTC
I have retested with a dvorak keymap, and with both us and dvorak on an other
computer with "nVidia Corporation NV34 [GeForce FX 5200] (rev a1)", it worked
in all cases.  Unfortunately I can't fix the issue without reproducing it.



Note You need to log in before you can comment on or make changes to this bug.