Bug 176826 - X and system freeze with ATI Radeon X600 (PCIE)
X and system freeze with ATI Radeon X600 (PCIE)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
card_R300e/M
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-03 09:22 EST by Trond H. Amundsen
Modified: 2010-10-21 23:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-04 17:44:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.92 KB, text/plain)
2006-01-03 09:22 EST, Trond H. Amundsen
no flags Details
Output from 'lspci -vv' (15.16 KB, text/plain)
2006-01-03 09:24 EST, Trond H. Amundsen
no flags Details
X log (42.02 KB, text/plain)
2006-01-03 09:25 EST, Trond H. Amundsen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 5853 None None None Never

  None (edit)
Description Trond H. Amundsen 2006-01-03 09:22:46 EST
Description of problem:

X freezes completely when the user tries to log in. In fact, the whole system
locks up and is not pingable. I don't know if there is a panic, since I don't
have a second console and the main console is used for.. well, X. I tried to
disable DRI, to no apparent effect. The system is a Dell Optiplex GX620.

This is using the stock radeon driver from RHEL4U2. I'll attach the X config,
output from 'lspci -vv' and the X log.

I've not tried the proprietary driver, nor do I want to.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1.EL.13.20

How reproducible:
Always.

Steps to Reproduce:
1. Buy a Dell Optiplex GX620 with optional ATI X600 card ;)
2. Install RHEL4U2 on it and configure X11
3. Log in via GDM
  
Actual results:
X freezes, the system freezes and is completely unusable.

Expected results:
User logged in normally.

Additional info:
Comment 1 Trond H. Amundsen 2006-01-03 09:22:46 EST
Created attachment 122711 [details]
xorg.conf
Comment 2 Trond H. Amundsen 2006-01-03 09:24:24 EST
Created attachment 122712 [details]
Output from 'lspci -vv'
Comment 3 Trond H. Amundsen 2006-01-03 09:25:32 EST
Created attachment 122713 [details]
X log
Comment 4 Trond H. Amundsen 2006-01-09 11:29:47 EST
Using netconsole, I got console messages. This is all it says when the user
logs in unsuccessfully:

Uhhuh. NMI received. Dazed and confused, but trying to continue
Uhhuh. NMI received. Dazed and confused, but trying to continue
You probably have a hardware problem with your RAM chips
You probably have a hardware problem with your RAM chips

BTW, the user got tired of waiting and resolved the problem by using the
proprietary driver from ATI. So that one works, at least.

Next: nmi_watchdog :)
Comment 5 Trond H. Amundsen 2006-01-09 11:58:14 EST
Bug #172335 seems to be the exact same problem, on Fedora.
Comment 6 Trond H. Amundsen 2006-01-20 07:30:38 EST
We've tried xorg-x11-6.8.2-1.EL.13.25, which is available for download via ftp
at ftp://people.redhat.com/mharris/testing/4E.

The login process got a bit further, but it still hangs after a short while.

BTW, it would be nice if someone from Red Hat responded, even though I'm
perfectly capable of having a conversation with myself...
Comment 7 James Ralston 2006-02-09 16:42:20 EST
Just FYI: Mike responded on my bug (bug 172335), and I've opened a bug on
freedesktop.org, as he requested:

https://bugs.freedesktop.org/show_bug.cgi?id=5853
Comment 8 Mike A. Harris 2006-03-08 01:55:57 EST
Try moving the "radeon.ko" kernel module temporarily out of the kernel
module search path into /root or somewhere else it wont find it, then
reboot the system and see if the X server starts.

There are some problems reported in newer Xorg releases on Radeon R300 and
newer hardware in which the X server and/or system hangs completely, which
have finally been tracked down to the kernel DRM module being loaded when
the X server's dri module is loaded - even for hardware to which there is no
DRI support (such as R300 and higher hardware including X600).


James: Thanks, I've just updated the upstream bug report also.  Hopefully this
issue turns out to be the kernel bug discovered.



(In reply to comment #6)
> BTW, it would be nice if someone from Red Hat responded, even though I'm
> perfectly capable of having a conversation with myself...

Official Red Hat Enterprise Linux support is provided by Red Hat support
services.  For official support you can file a web support ticket at
http://www.redhat.com/support or via telephone at 1-888-RED-HAT1 depending
on the support contract you have arranged with Red Hat.  Red Hat support
services provide the support mechanism for Red Hat Enterprise Linux.

Bugzilla is just for tracking bugs in the OS releases, and is not a RHEL
support mechanism.  For official support, always use Red Hat support
services for reporting issues.

Comment 9 Trond H. Amundsen 2006-04-03 10:31:16 EDT
Mike, I've tried moving the radeon module away as you suggested, to no
effect. The system still hangs completely when a user tries to log in.
I'll follow the thread on Freedesktop's bugzilla, thanks for the tip.

I'll update this bug whenever I have new information.

(And I'm sorry for the outburst.. But being a university, with just the
educational license, your bugzilla is the only way for us to report bugs
and hopefully get them fixed.)
Comment 10 Jonathan Peatfield 2006-08-19 10:29:56 EDT
The org bugzilla https://bugs.freedesktop.org/show_bug.cgi?id=5853 above
says the bug was fixed in June.  Can we assume that the Radeon fixes
mentioned in https://rhn.redhat.com/errata/RHBA-2006-0412.html include
attempts to fix this?

If it does we might actually get some of our Dell systems upgraded from
EL3 this year...
[ in EL4 update 3 the graphical installer freezes the machine -- text installs
work but then it freezes if you log in, and anyway text mode doesn't seem to
allow one to set up lvm in a sane way... ]
Comment 11 Adam Jackson 2006-09-07 14:25:21 EDT
That errata does not address any PCIE issues, it only contains fixes for various
R100-class cards.  Unfortunately we probably aren't going to have the resources
to address this in the 4.5 timeframe, but I suspect this is a solvable problem.

It would be helpful if you could attempt to reproduce this issue with the radeon
driver in FC5.  The fdo bug report indicates that this was fixed in 6.5.8, which
is a bit newer than the one we have in RHEL4, but the changes that fixed it
might be small enough to be a backport candidate.
Comment 13 RHEL Product and Program Management 2006-09-07 16:00:13 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 14 Adam Jackson 2006-09-15 19:10:41 EDT
Gah, not a WONTFIX.
Comment 15 Matěj Cepl 2007-06-26 07:19:27 EDT
Reporter, could you confirm please, that this bug still could be reproduced with
the latest release of RHEL4?
Comment 16 Trond H. Amundsen 2007-07-05 10:25:22 EDT
The user confirms that this bug still exists with RHEL4.5.
Comment 17 Matěj Cepl 2007-10-23 07:36:28 EDT
Reporter, could you please explain me the status of your RHEL support? I will
certainly not close this bug if you have unsupported distribution (e.g., CentOS)
but if you have RH support contract, it would be more helpful to log
into the Red Hat support website at http://www.redhat.com/support and file a
support ticket, or alternatively contact Red Hat Global Support Services at
1-888-RED-HAT1 to speak directly with a support associate and escalate an
issue.
Comment 18 Trond H. Amundsen 2007-10-24 05:25:27 EDT
The system is a genuine RHEL5, not CentOS :) And yes, we have a RH support
contract now, we didn't have support when this bug was first filed (edu license).

This bug is hardly critical to us, which is why I've completely forgotten about
it and have not created a support ticket for it. We are moving users to RHEL5,
which I don't believe has this problem anyway, and the proprietary ATI driver is
an acceptable workaround for RHEL4 systems. Also, this is an old video card that
isn't sold with newer hardware. Consequently, in my world, the bug is going away
by its own.

I don't see the need to create a support ticket for this one. I'm choosing the
path of least resistance ;) Feel free to close this bug if you don't deem it
important enough to fix. If, for some unknown reason, the bug becomes an
important issue for us, I'll create a support ticket.
Comment 19 Trond H. Amundsen 2007-10-24 05:26:38 EDT
Bah! The system is RHEL4, of course, not RHEL5.
Comment 22 Russell Doty 2010-06-04 17:44:52 EDT
Per comment 21, this was closed through IT.

Note You need to log in before you can comment on or make changes to this bug.