Bug 176830 - fstab-sync --> error: libhal_ctx_init_direct: (null): (null)
fstab-sync --> error: libhal_ctx_init_direct: (null): (null)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-03 10:06 EST by Enrico Scholz
Modified: 2013-03-13 00:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-03 11:12:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2006-01-03 10:06:47 EST
Description of problem:

| # fstab-sync
| error: libhal_ctx_init_direct: (null): (null)


'strace' does not tell something suspicious:

| set_thread_area({entry_number:-1 -> 6, base_addr:0xb7fba6c0, limit:1048575, seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0, useable:1}) = 0
| mprotect(0x4d81e000, 8192, PROT_READ)   = 0
| mprotect(0x4efe7000, 4096, PROT_READ)   = 0
| mprotect(0x4d6f7000, 4096, PROT_READ)   = 0
| munmap(0xb7fbc000, 129544)              = 0
| getpid()                                = 4005
| brk(0)                                  = 0x8050000
| brk(0x8071000)                          = 0x8071000
| write(2, "error: libhal_ctx_init_direct: ("..., 46error: libhal_ctx_init_direct: (null): (null)
| ) = 46
| exit_group(0)                           = ?

Happens both with and without a running messagebus daemon and as you
can see in the strace above, local configuration will not be read.


Version-Release number of selected component (if applicable):

hal-0.5.5.1-2.1
hal-0.5.2-2


How reproducible:

100%
Comment 1 John (J5) Palmieri 2006-01-03 11:12:39 EST
Not a bug.  You can't run fstab-sync from the command line since it requires env
variables set up by hal to talk to hal directly (perhaps upstream should fix
that error message).  

Note You need to log in before you can comment on or make changes to this bug.