Bug 176835 - smarctl needs -d ata instead of -d libata (wrong suggestion for the user)
smarctl needs -d ata instead of -d libata (wrong suggestion for the user)
Status: CLOSED DUPLICATE of bug 206334
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-utils (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-03 10:36 EST by Milan Kerslager
Modified: 2008-09-30 10:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-30 10:18:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2006-01-03 10:36:56 EST
The current Beta channel for RHEL4 deliver S.M.A.R.T. support for SATA drives.

The smartctl utility needs "-d ata" parametr to work with SATA drive. This
should be picked up automagically as smartctl knows about SATA drive and
complain that one should use "-d libata" (which is wrong too).

Expected result: smartctl works without complains on SATA drives too.
Comment 1 Tomas Mraz 2006-09-13 14:09:33 EDT
The autodetection of SATA drives must be implemented upstream before we can
consider backporting that to older RHEL releases.
Comment 2 Milan Kerslager 2006-09-13 14:54:20 EDT
Actual version of smartctl fails on i386 and x86_64 without telling a user that
"-d ata" should be used to see SMART logs and values. This suggestion has been
removed since this bug has been filled. Why?

Current version does not suggest wrong "libata" parameter to the user as error
message or in the man page.

However smartd daemon does nor run tests on SATA discs because lack of
autodetection. How one should monitor discs in enterprise environment? See bug
#206334.
Comment 3 Milan Kerslager 2006-09-13 15:04:26 EDT
smartctl /dev/sda (sda is SATA disc) does not return error code even fails on SATA

With -a parameter, returns code 4.

This is wrong, please fix.
Comment 4 Tomas Mraz 2006-09-20 02:27:14 EDT
Please use one bug report for one bug. Also always please add the exact package
version to the report.
Comment 5 Milan Kerslager 2006-09-20 13:23:50 EDT
Filled as bug #207324.
Comment 6 Tomas Mraz 2006-09-20 14:09:34 EDT
Re comment #2: This is probably caused by some change in kernel as there was no
change in the smartctl binary which could affect that. This change must have
broken the SATA detection in the smartmontools SCSI driver.
Comment 7 Milan Kerslager 2007-04-20 02:24:13 EDT
As of kernel-utils-2.4-13.1.83 the bug still exists:

smartctl -a /dev/sda - returns 4 (this is Ok)
smartctl /dev/sda - returns 0 (this is not Ok, see comment #3)
Comment 8 RHEL Product and Program Management 2008-09-24 16:24:52 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Michal Hlavinka 2008-09-30 10:18:14 EDT
smartctl now autodetects SATA disks and doesn't need any parameter (-d ata).
Tested with kernel-utils-2.4-14.1.117

*** This bug has been marked as a duplicate of bug 206334 ***

Note You need to log in before you can comment on or make changes to this bug.