Bug 176852 - Latest jrocket packages do not update the /usr/bin/java symlink.
Latest jrocket packages do not update the /usr/bin/java symlink.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: java-1.4.2-bea (Show other bugs)
4.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lillian Angel
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-03 14:44 EST by Tom Kincaid
Modified: 2010-10-18 15:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-18 15:33:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Kincaid 2006-01-03 14:44:55 EST
Description of problem:

The version of the jrockit  packages in the RHEL 4 U3 Beta, do not change the
default java version when installed. 

This is a regression from the previous set of packages. Please see the console
session below. With the previously shipped packages, the /usr/bin/java linked
was changed to point to the appropriate locally installed jvm.

The packages that are part of the U3 2006:009 Errata do not do this. Instead
the /usr/bin/java link continues to point to gcj.

I think we should try to fix this. It is an obvious regression.


.qa.[root@x86_64-4AS tps]# java -version
java version "1.4.2"
gcj (GCC) 3.4.4 20050721 (Red Hat 3.4.4-2)
Copyright (C) 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

.qa.[root@x86_64-4AS tps]# rpm -ihv `cat pkgnames-old-4AS-x86_64.list`
error: open of java-1.4.2-bea failed: No such file or directory
error: open of java-1.4.2-bea-console failed: No such file or directory
error: open of java-1.4.2-bea-devel failed: No such file or directory
.qa.[root@x86_64-4AS tps]# rpm -ivh `cat old-files-4AS-x86_64.list`
Preparing...                ########################################### [100%]
   1:java-1.4.2-bea         ########################################### [ 33%]
   2:java-1.4.2-bea-console ########################################### [ 67%]
   3:java-1.4.2-bea-devel   ########################################### [100%]
.qa.[root@x86_64-4AS tps]# java -version
java version "1.4.2_05"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_05-b04)
BEA WebLogic JRockit(TM) 1.4.2_05 JVM R24.4.1-1 (build
ari-38317-20041124-1225-linux-ia32, Native Threads, GC strategy: parallel)
.qa.[root@x86_64-4AS tps]# which java
/usr/bin/java
.qa.[root@x86_64-4AS tps]# rpm -e `cat pkgnames-old-4AS-x86_64.list`
.qa.[root@x86_64-4AS tps]# java -version
java version "1.4.2"
gcj (GCC) 3.4.4 20050721 (Red Hat 3.4.4-2)
Copyright (C) 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

.qa.[root@x86_64-4AS tps]# which java
/usr/bin/java
.qa.[root@x86_64-4AS tps]# rpm -ivh `cat new-files-4AS-x86_64.list`
warning:
/mnt/redhat/beehive/updates/dist/4AS-LACD/x86_64/java-1.4.2-bea-1.4.2.08-1jpp_40rh.i686.rpm:
V3 DSA signature: NOKEY, key ID 897da07a
Preparing...                ########################################### [100%]
   1:java-1.4.2-bea         ########################################### [ 33%]
   2:java-1.4.2-bea-console ########################################### [ 67%]
   3:java-1.4.2-bea-devel   ########################################### [100%]
.qa.[root@x86_64-4AS tps]# java -version
java version "1.4.2"
gcj (GCC) 3.4.4 20050721 (Red Hat 3.4.4-2)
Copyright (C) 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

.qa.[root@x86_64-4AS tps]# which java
/usr/bin/java
.qa.[root@x86_64-4AS tps]#




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Thomas Fitzsimmons 2006-01-06 13:08:04 EST
I'm investigating this.
Comment 2 Thomas Fitzsimmons 2006-01-09 12:45:26 EST
Do you still have your test environment around?  If so can you post the output of:

/usr/sbin/alternatives --display java

and

/usr/sbin/alternatives --display javac

I think the problem is that the BEA RPMs have an alternatives priority of 1420
when they should have a priority of 1428.  This is a bug in the SRPM that BEA
sent me; I'll fix this, rebuild the packages and let BEA know about the priority
field.
Comment 3 Thomas Fitzsimmons 2006-01-09 13:01:08 EST
The new packages are in beehive:

1.4.2.08-1jpp_41rh in dist-3.0E-lacd-errata-candidate
1.4.2.08-1jpp_42rh in dist-4E-lacd-errata-candidate
Comment 4 David Lawrence 2006-04-18 10:43:38 EDT
PASSES_QA status has been deprecated in favor of VERIFIED. Changing status to
VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.