Bug 176859 - yumex and other admin tools will not run
yumex and other admin tools will not run
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-03 15:52 EST by Peter Hammond
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-03 16:14:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Hammond 2006-01-03 15:52:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
when trying to run admin tools like yumex or system-install-packages I am prompted  for the root password, on entering it, the yellow Shield appears indicating I have authorisation but nothing else happens. If I try and run from the command line I get the following output:

[root@localhost My Downloads]# yumex
/usr/bin/python: /lib/libc.so.6: version `GLIBC_2.4' not found (required by /usr/lib/libpython2.4.so.1.0)
[root@localhost My Downloads]# 

Version-Release number of selected component (if applicable):
glibc-2.3.5-10.3  python-2.4.2-2.1  kernel-2.6.14-1.1653_FC4

How reproducible:
Always

Steps to Reproduce:
1. enter yumex at the command prompt
2.
3.
  

Actual Results:  /usr/bin/python: /lib/libc.so.6: version `GLIBC_2.4' not found (required by /usr/lib/libpython2.4.so.1.0)

Expected Results:  yum extender interface should appear 

Additional info:
Comment 1 Jakub Jelinek 2006-01-03 16:14:52 EST
You are trying to run a program built on rawhide against FC4 glibc, don't do
that.  If you installed libpython2.4.so.1.0 with rpm, I wonder how you managed
to do so, because it clearly ought to have libc.so.6(GLIBC_2.4) requirement
that is not satisfied by FC4 glibc (unless you forced it).
Comment 2 Peter Hammond 2006-01-03 16:22:13 EST
don't know how to force it!

how can i fix it?
Comment 3 Peter Hammond 2006-01-03 16:23:31 EST
(In reply to comment #1)
> You are trying to run a program built on rawhide against FC4 glibc, don't do
> that.  If you installed libpython2.4.so.1.0 with rpm, I wonder how you managed
> to do so, because it clearly ought to have libc.so.6(GLIBC_2.4) requirement
> that is not satisfied by FC4 glibc (unless you forced it).


I don't know how to force it.

Can I fix it? if so, can you please tell me how.
Comment 4 Jakub Jelinek 2006-01-03 16:38:19 EST
You haven't said what exactly you installed, how, from where.
The only fix is to use only FC4 or earlier compiled programs on FC4,
glibc is not forward compatible, just backwards compatible.
So depending on where you got that libpython2.4.so.1.0 from, you either
want to install some other rpm that provides it and has been built for FC4,
or e.g. rebuild src.rpm for the one built for rawhide on your FC4 system.
Comment 5 Peter Hammond 2006-01-03 16:46:51 EST
(In reply to comment #4)
> You haven't said what exactly you installed, how, from where.
> The only fix is to use only FC4 or earlier compiled programs on FC4,
> glibc is not forward compatible, just backwards compatible.
> So depending on where you got that libpython2.4.so.1.0 from, you either
> want to install some other rpm that provides it and has been built for FC4,
> or e.g. rebuild src.rpm for the one built for rawhide on your FC4 system.

I tried to install warsow, but ./configure said it was missing libstdc++ and
libc.so.6 so I downloaded glibc-2.3.5-10.3.i386.rpm and installed it and
installed glibc++ from the Linux Magazine FC4 dvd 

Note You need to log in before you can comment on or make changes to this bug.