Bug 17686 - problem with Xree86 libs
problem with Xree86 libs
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-19 11:35 EDT by Knut J BJuland
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 12:58:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2000-09-19 11:35:27 EDT
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:579: checking host system type
configure:615: checking for a BSD compatible install
configure:668: checking whether build environment is sane
configure:725: checking whether make sets ${MAKE}
configure:771: checking for working aclocal
configure:784: checking for working autoconf
configure:797: checking for working automake
configure:810: checking for working autoheader
configure:823: checking for working makeinfo
configure:838: checking whether to enable maintainer-specific portions of
Makefiles
configure:863: checking for egcs
configure:976: checking whether the C compiler (egcs  ) works
configure:992: egcs -o conftest    conftest.c  1>&5
configure:1018: checking whether the C compiler (egcs  ) is a
cross-compiler
configure:1023: checking whether we are using GNU C
configure:1051: checking whether egcs accepts -g
configure:1083: checking how to run the C preprocessor
configure:1164: checking whether egcs needs -traditional
configure:1212: checking for ranlib
configure:1240: checking whether ln -s works
configure:1261: checking whether byte ordering is bigendian
configure:1422: checking build system type
configure:1451: checking for ld used by egcs
configure:1513: checking if the linker (/usr/bin/ld) is GNU ld
configure:1529: checking for BSD-compatible nm
ltconfig:581: checking whether we are using GNU C
ltconfig:589: egcs -E conftest.c
ltconfig:603: checking for object suffix
ltconfig:604: egcs -c -g -O2  conftest.c 1>&5
ltconfig:629: checking for executable suffix
ltconfig:630: egcs -o conftest -g -O2   conftest.c  1>&5
ltconfig:776: checking if egcs PIC flag -fPIC works
ltconfig:777: egcs -c -g -O2 -fPIC -DPIC  conftest.c 1>&5
ltconfig:829: checking if egcs supports -c -o file.o
ltconfig:830: egcs -c -g -O2 -o out/conftest2.o  conftest.c 1>&5
ltconfig:862: checking if egcs supports -c -o file.lo
ltconfig:863: egcs -c -g -O2 -c -o conftest.lo  conftest.c 1>&5
ltconfig:914: checking if egcs supports -fno-rtti -fno-exceptions
ltconfig:915: egcs -c -g -O2 -fno-rtti -fno-exceptions -c conftest.c 
conftest.c 1>&5
ltconfig:958: checking if egcs static flag -static works
ltconfig:959: egcs -o conftest -g -O2   -static conftest.c  1>&5
GNU ld version 2.10.90 (with BFD 2.10.0.18)
ltconfig:1653: checking if global_symbol_pipe works
ltconfig:1654: egcs -c -g -O2  conftest.c 1>&5
ltconfig:1657: eval "/usr/bin/nm -B conftest.o | sed -n -e 's/^.*[     
]\([ABCDGISTW]\)[       ][      ]*\(\)\([_A-Za-z][_A-Za-z0-9]*\)$/\1 \2\3
\3/p' > conftest.nm"
ltconfig:1709: egcs -o conftest -g -O2 -fno-builtin -fno-rtti
-fno-exceptions   conftest.c conftstm.o 1>&5
ltconfig:2248: checking for dlopen in -ldl
ltconfig:2269: egcs -o conftest -g -O2 -fno-builtin -fno-rtti
-fno-exceptions   conftest.c -ldl   1>&5
ltconfig:2488: checking for dlfcn.h
ltconfig:2498: egcs -c -g -O2 -fno-builtin -fno-rtti -fno-exceptions 
conftest.c 1>&5 >/dev/null 2>conftest.out
ltconfig:2526: checking whether a program can dlopen itself
ltconfig:2580: egcs -o conftest -g -O2 -fno-builtin -fno-rtti
-fno-exceptions  -DHAVE_DLFCN_H  -Wl,--export-dynamic conftest.c -ldl  1>&5
ltconfig:2599: checking whether a statically linked program can dlopen
itself
ltconfig:2653: egcs -o conftest -g -O2 -fno-builtin -fno-rtti
-fno-exceptions  -DHAVE_DLFCN_H  -Wl,--export-dynamic -static conftest.c
-ldl  1>&5
ltconfig: failed program was:
#line 2607 "ltconfig"

#if HAVE_DLFCN_H
#include <dlfcn.h>
#endif

#include <stdio.h>

#ifdef RTLD_GLOBAL
# define LTDL_GLOBAL    RTLD_GLOBAL
#else
# ifdef DL_GLOBAL
#  define LTDL_GLOBAL   DL_GLOBAL
# else
#  define LTDL_GLOBAL   0
# endif
#endif

/* We may have to define LTDL_LAZY_OR_NOW in the command line if we
   find out it does not work in some platform. */
#ifndef LTDL_LAZY_OR_NOW
# ifdef RTLD_LAZY
#  define LTDL_LAZY_OR_NOW      RTLD_LAZY
# else
#  ifdef DL_LAZY
#   define LTDL_LAZY_OR_NOW     DL_LAZY
#  else
#   ifdef RTLD_NOW
#    define LTDL_LAZY_OR_NOW    RTLD_NOW
#   else
#    ifdef DL_NOW
#     define LTDL_LAZY_OR_NOW   DL_NOW
#    else
#     define LTDL_LAZY_OR_NOW   0
#    endif
#   endif
#  endif
# endif
#endif

fnord() { int i=42;}
main() { void *self, *ptr1, *ptr2;
self=dlopen(0,LTDL_GLOBAL|LTDL_LAZY_OR_NOW);
    if(self) { ptr1=dlsym(self,"fnord"); ptr2=dlsym(self,"_fnord");
    if(ptr1 || ptr2) { dlclose(self); exit(0); } } exit(1); } 

configure:1807: checking for main in -lmlib
configure:1822: egcs -o conftest -g -O2   conftest.c -lmlib
-L/opt/SUNWmlib/lib  1>&5
/usr/bin/ld: cannot find -lmlib
collect2: ld returned 1 exit status
configure: failed program was:
#line 1815 "configure"
#include "confdefs.h"

int main() {
main()
; return 0; }
configure:1909: checking for /dev/mga_vid
configure:1940: checking for main in -lmlib
configure:2045: checking for X
configure:2112: egcs -E  conftest.c >/dev/null 2>conftest.out
configure:2188: egcs -o conftest -g -O2   conftest.c -lXt  1>&5
/usr/X11R6/lib/libX11.so.6: undefined reference to `getpwuid_r@GLIBC_2.1.2'
/usr/X11R6/lib/libX11.so.6: undefined reference to `shmctl@GLIBC_2.2'
/usr/X11R6/lib/libX11.so.6: undefined reference to `getpwnam_r@GLIBC_2.1.2'
collect2: ld returned 1 exit status
configure: failed program was:
#line 2181 "configure"
#include "confdefs.h"

int main() {
XtMalloc()
; return 0; }
configure:2359: checking for dnet_ntoa in -ldnet
configure:2378: egcs -o conftest -g -O2   conftest.c -ldnet   1>&5
/usr/bin/ld: cannot find -ldnet
collect2: ld returned 1 exit status
configure: failed program was:
#line 2367 "configure"
#include "confdefs.h"
/* Override any egcs2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a egcs2
    builtin and then its argument prototype would still apply.  */
char dnet_ntoa();

int main() {
dnet_ntoa()
; return 0; }
configure:2400: checking for dnet_ntoa in -ldnet_stub
configure:2419: egcs -o conftest -g -O2   conftest.c -ldnet_stub   1>&5
/usr/bin/ld: cannot find -ldnet_stub
collect2: ld returned 1 exit status
configure: failed program was:
#line 2408 "configure"
#include "confdefs.h"
/* Override any egcs2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a egcs2
    builtin and then its argument prototype would still apply.  */
char dnet_ntoa();

int main() {
dnet_ntoa()
; return 0; }
configure:2448: checking for gethostbyname
configure:2476: egcs -o conftest -g -O2   conftest.c  1>&5
configure:2546: checking for connect
configure:2574: egcs -o conftest -g -O2   conftest.c  1>&5
configure:2638: checking for remove
configure:2666: egcs -o conftest -g -O2   conftest.c  1>&5
configure:2730: checking for shmat
configure:2758: egcs -o conftest -g -O2   conftest.c  1>&5
configure:2831: checking for IceConnectionNumber in -lICE
configure:2850: egcs -o conftest -g -O2   -L/usr/X11R6/lib conftest.c
-lICE   1>&5
configure:2875: checking for XvShmCreateImage in -lXv
t
his is the problem
configure:2894: egcs -o conftest -g -O2   conftest.c -lXv 
-L/usr/X11R6/lib  -lSM -lICE -lXext -lX11   1>&5
/usr/X11R6/lib/libX11.so: undefined reference to `getpwuid_r@GLIBC_2.1.2'
/usr/X11R6/lib/libX11.so: undefined reference to `shmctl@GLIBC_2.2'
/usr/X11R6/lib/libX11.so: undefined reference to `getpwnam_r@GLIBC_2.1.2'
collect2: ld returned 1 exit status
configure: failed program was:


#line 2883 "configure"
#include "confdefs.h"
/* Override any egcs2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a egcs2
    builtin and then its argument prototype would still apply.  */
char XvShmCreateImage();

int main() {
XvShmCreateImage()
; return 0; }
configure:2921: checking for SMP
Comment 1 Knut J BJuland 2000-11-14 12:58:06 EST
the problem has been solved with later version of program, and later version off
gcc.
Comment 2 Mike A. Harris 2001-03-01 16:01:11 EST
I've WORKSFORME'd this because there is no WORKSFORYOU setting.  It was a
tossup with NOTABUG.  I don't get to use WORKSFORME too often though, so
I figured I'd take the opportunity to use it now.  It feels good.  ;o)

Note You need to log in before you can comment on or make changes to this bug.