Bug 176863 - [EasyFix] 'Requires: sed' ignored in udev.spec
[EasyFix] 'Requires: sed' ignored in udev.spec
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-03 16:23 EST by Chris Schanzle
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-24 10:56:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Schanzle 2006-01-03 16:23:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
With regards to  http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/udev-078-3.i386.rpm

rpm -qip udev-078-3.i386.rpm

has 'Requires: sed ' as the last line of the description.  Confirmed that 
  rpm -qip --requires udev-078-3.i386.rpm
does not list 'sed' as a requirement as intended.


Version-Release number of selected component (if applicable):
udev-078-3

How reproducible:
Always

Steps to Reproduce:
1.  download udev-078-3.i386.rpm
2.  rpm -qip udev-078-3.i386.rpm
Note last line.


Actual Results:  "Requires: sed" is displayed as part of the description.

Expected Results:  'sed' should be a rpm install requirement, not part of its description.

Additional info:

Moving Requires line per below seems to fix it.  Could this actually be an RPM bug?

 diff -u udev.spec{~,}
--- udev.spec~  2006-01-03 15:56:59.000000000 -0500
+++ udev.spec   2006-01-03 16:02:33.000000000 -0500
@@ -35,13 +35,13 @@

 BuildRequires: pam-devel glib2-devel bison
 Requires: pam
+Requires: sed
+

 %description
 The udev package contains an implementation of devfs in
 userspace using sysfs and netlink.

-Requires: sed
-
 %define add %{nil}

 %prep

Note You need to log in before you can comment on or make changes to this bug.