Bug 1768897 - nfs-utils-coreos does not declare dependency on rpcbind
Summary: nfs-utils-coreos does not declare dependency on rpcbind
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils
Version: rawhide
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-05 13:48 UTC by Christian Glombek
Modified: 2020-02-26 18:46 UTC (History)
6 users (show)

Fixed In Version: nfs-utils-2.4.1-2.rc1.fc32, nfs-utils-2.4.1-2.rc1.fc31 nfs-utils-2.4.2-1.rc2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-27 00:24:33 UTC
Type: Bug


Attachments (Terms of Use)

Description Christian Glombek 2019-11-05 13:48:49 UTC
Description of problem:

A number of problems arose with nfs-utils-coreos when running end to end tests for OKD-on-FCoS, with the following err messages:

Failed to start rpc-statd.service: Unit rpcbind.socket not found.

rpc.statd[1236]: Failed to open directory sm: No such file or directory


Version-Release number of selected component (if applicable):
2.4.1-1.rc1


How reproducible:
Prow CI FCOS e2e tests
see https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/openshift_installer/2548/pull-ci-openshift-installer-fcos-e2e-aws/26


Actual results:
Failed to start rpc-statd.service: Unit rpcbind.socket not found.

rpc.statd[1236]: Failed to open directory sm: No such file or directory


Expected results:
rpcbind.socket exists,
sm dir exists
no errors

Additional info:

Comment 1 Christian Glombek 2019-11-05 14:21:55 UTC
PR in https://src.fedoraproject.org/rpms/nfs-utils/pull-request/8

Comment 2 Steve Dickson 2019-11-05 16:35:53 UTC
(In reply to Christian Glombek from comment #1)
> PR in https://src.fedoraproject.org/rpms/nfs-utils/pull-request/8

I guess I don't understand this the first diff of the patch
@@ -42,8 +42,6 @@ Provides: sm-notify   = %{epoch}:%{version}-%{release}
 Provides: start-statd = %{epoch}:%{version}-%{release}
 
 License: MIT and GPLv2 and GPLv2+ and BSD
-Requires: rpcbind, sed, gawk, grep
-Requires: kmod, keyutils, quota
 BuildRequires: libevent-devel libcap-devel libuuid-devel
 BuildRequires: libtirpc-devel libblkid-devel
 BuildRequires: krb5-libs >= 1.4 autoconf >= 2.57 openldap-devel >= 2.2
@@ -59,8 +57,10 @@ Requires(pre): coreutils
 Requires(preun): coreutils
 Requires: libnfsidmap libevent
 Requires: libtirpc >= 0.2.3-1 libblkid libcap libmount
-%{?systemd_requires}
 Requires: gssproxy => 0.7.0-3
+Requires: rpcbind, sed, gawk, grep
+Requires: kmod, keyutils, quota
+%{?systemd_requires}
 
 %package -n nfs-utils-coreos
 Summary: Minimal NFS utilities for supporting clients

Why are you moving those Requires: down to after the Requires: gssproxy => 0.7.0-3?

Comment 3 Christian Glombek 2019-11-05 18:59:39 UTC
That isn't strictly necessary, but I believe it's generically a good practice to group all Requires together in one place. Can revert that part if you prefer.

Comment 4 Christian Glombek 2019-11-05 19:01:55 UTC
*generally

Comment 5 Christian Glombek 2019-11-06 15:38:55 UTC
Please let me know! We need a new build of the RPM with this change to land in Fedora CoreOS as soon as possible, as it's blocking our work on OKD-on-FCOS right now.

Comment 6 Fedora Update System 2019-11-26 13:14:45 UTC
FEDORA-2019-b4ef1802bf has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b4ef1802bf

Comment 7 Fedora Update System 2019-11-26 13:15:28 UTC
FEDORA-2019-6c65782f48 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6c65782f48

Comment 8 Fedora Update System 2019-11-27 00:24:33 UTC
nfs-utils-2.4.1-2.rc1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2019-12-09 02:27:49 UTC
nfs-utils-2.4.2-1.rc2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Ganapathi Kamath 2020-02-25 05:46:51 UTC
Unsure if related

there is some conflict between nfs-utils-coreos and nfs-utils
when installing a package that pulls in nfs-utils

$ cat /etc/redhat-release 
Fedora release 31 (Thirty One)

$ rpm-ostree install libvirt
==== AUTHENTICATING FOR org.projectatomic.rpmostree1.install-uninstall-packages ====
Authentication is required to install and remove software
Multiple identities can be used for authentication:
 1.  CoreOS Admin (core)
 2.  guser
Choose identity to authenticate as (1-2): 2
Password: 
==== AUTHENTICATION COMPLETE ====
Checking out tree 2ba7bb9... done
Enabled rpm-md repositories: updates fedora
rpm-md repo 'updates' (cached); generated: 2020-02-24T00:57:18Z
rpm-md repo 'fedora' (cached); generated: 2019-10-23T22:52:47Z
Importing rpm-md... done
Resolving dependencies... done
Will download: 100 packages (36.9?MB)
Downloading from 'updates'... done
Downloading from 'fedora'... done
Importing packages... done
Checking out packages... done
error: Checkout nfs-utils-1:2.4.3-0.fc31.x86_64: Hardlinking 40/acdd78e2329013e259dc0a13e5922a2f7cfdd2baff970cdacd1a049706b292.file to mount.nfs: File exists


$ rpm-ostree status
State: idle
AutomaticUpdates: disabled
Deployments:
* ostree://fedora:fedora/x86_64/coreos/stable
                   Version: 31.20200127.3.0 (2020-02-10T21:52:39Z)
                BaseCommit: 2ba7bb9678d86fc469f1920a03c270d7057e0b93d06fcd1a437f1f79bdc26d83
              GPGSignature: Valid signature by 7D22D5867F2A4236474BF7B850CB390B3C3359C4
           LayeredPackages: dnf

  ostree://fedora:fedora/x86_64/coreos/stable
                   Version: 31.20200127.3.0 (2020-02-10T21:52:39Z)
                    Commit: 2ba7bb9678d86fc469f1920a03c270d7057e0b93d06fcd1a437f1f79bdc26d83
              GPGSignature: Valid signature by 7D22D5867F2A4236474BF7B850CB390B3C3359C4

Comment 11 Christian Glombek 2020-02-25 16:37:13 UTC
This should work with 'rpm-ostree install libvirt --remove nfs-utils-coreos'

Comment 12 Dusty Mabe 2020-02-25 18:50:48 UTC
 (In reply to Ganapathi Kamath from comment #10)
> Unsure if related
> 
> there is some conflict between nfs-utils-coreos and nfs-utils
> when installing a package that pulls in nfs-utils

The problem here is because the nfs-utils (nfs-utils-2.4.3-0.fc31.x86_64) that is getting pulled in is a different version than the nfs-utils-coreos (nfs-utils-coreos-2.4.3-0.fc31.x86_64) that is in the tree. I can successfully install it on the testing branch because it includes the newer version of nfs-utils-coreos in the base ostree:


```
[core@dhcp137-238 ~]$ rpm-ostree install nfs-utils
==== AUTHENTICATING FOR org.projectatomic.rpmostree1.install-uninstall-packages ====
Authentication is required to install and remove software
Authenticating as: CoreOS Admin (core)
Password: 
[core@dhcp137-238 ~]$ sudo rpm-ostree install nfs-utils
Checking out tree d601dce... done
Enabled rpm-md repositories: updates fedora
Updating metadata for 'updates'... done
rpm-md repo 'updates'; generated: 2020-02-24T00:57:18Z
Updating metadata for 'fedora'... done
rpm-md repo 'fedora'; generated: 2019-10-23T22:52:47Z
Importing rpm-md... done
Resolving dependencies... done
Will download: 15 packages (12.6 MB)
Downloading from 'updates'... done
Downloading from 'fedora'... done
Importing packages... done
Checking out packages... done
Running pre scripts... done
Running post scripts... done
Running posttrans scripts... done
Writing rpmdb... done
Writing OSTree commit... done
Staging deployment... done
Freed: 458.3 MB (pkgcache branches: 0)
Added:
  gdbm-libs-1:1.18.1-1.fc31.x86_64
  gssproxy-0.8.2-5.fc31.x86_64
  libev-4.27-1.fc31.x86_64
  libverto-libev-0.3.0-8.fc31.x86_64
  libxcrypt-compat-4.4.14-1.fc31.x86_64
  nfs-utils-1:2.4.3-0.fc31.x86_64
  python-pip-wheel-19.1.1-7.fc31.noarch
  python-setuptools-wheel-41.2.0-1.fc31.noarch
  python-unversioned-command-3.7.6-2.fc31.noarch
  python3-3.7.6-2.fc31.x86_64
  python3-libs-3.7.6-2.fc31.x86_64
  python3-pip-19.1.1-7.fc31.noarch
  python3-setuptools-41.2.0-1.fc31.noarch
  quota-1:4.05-7.fc31.x86_64
  quota-nls-1:4.05-7.fc31.noarch
Run "systemctl reboot" to start a reboot
[core@dhcp137-238 ~]$ 
[core@dhcp137-238 ~]$ rpm-ostree status
State: idle
AutomaticUpdates: disabled
Deployments:
  ostree://fedora:fedora/x86_64/coreos/testing
                   Version: 31.20200223.2.0 (2020-02-24T16:54:11Z)
                BaseCommit: d601dced7394413eac83302a40ce9443b4a7f0e5123d5050074b4fc13d96cfdb
              GPGSignature: Valid signature by 7D22D5867F2A4236474BF7B850CB390B3C3359C4
                      Diff: 15 added
           LayeredPackages: nfs-utils

● ostree://fedora:fedora/x86_64/coreos/testing
                   Version: 31.20200223.2.0 (2020-02-24T16:54:11Z)
                    Commit: d601dced7394413eac83302a40ce9443b4a7f0e5123d5050074b4fc13d96cfdb
              GPGSignature: Valid signature by 7D22D5867F2A4236474BF7B850CB390B3C3359C4

  ostree://fedora:fedora/x86_64/coreos/testing
                   Version: 31.20200210.2.0 (2020-02-10T21:52:48Z)
                    Commit: 3e4a6a48ed8d6817081c902bc2aa2bbe9df3302e659d4f42d933f9abb22914e8
              GPGSignature: Valid signature by 7D22D5867F2A4236474BF7B850CB390B3C3359C4

```

Comment 13 Dusty Mabe 2020-02-25 18:52:59 UTC
(In reply to Dusty Mabe from comment #12)

> The problem here is because the nfs-utils (nfs-utils-2.4.3-0.fc31.x86_64)
> that is getting pulled in is a different version than the nfs-utils-coreos
> (nfs-utils-coreos-2.4.3-0.fc31.x86_64) that is in the tree.

Correction: Meant to say:

The problem here is because the nfs-utils (nfs-utils-2.4.3-0.fc31.x86_64) that is getting pulled in is a different version than the nfs-utils-coreos (nfs-utils-coreos-2.4.2-3.rc3.fc31.x86_64) that is in the tree.

Comment 14 Ganapathi Kamath 2020-02-26 18:46:40 UTC
thx for quick response

confirming that following worked (tried afresh on 31.202002103.0)
$ sudo rpm-ostree override remove nfs-utils-coreos
$ sudo rpm-ostree install libvirt

* a diff between old rpm -qil nfs-utils-coreos (2.4.2) and new rpm -qa nfs-utils (2.4.3) indicates that old package was a subset, at least outside of /usr/lib/.build-id


Note You need to log in before you can comment on or make changes to this bug.