This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 17694 - Won't configure ALi M5451 PCI South Bridge Audio
Won't configure ALi M5451 PCI South Bridge Audio
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-19 11:56 EDT by Richard D. Payne
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-19 08:02:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Enable trident sound driver when CONFIG_ALPHA_GENERIC (1.22 KB, patch)
2000-09-21 09:52 EDT, Richard D. Payne
no flags Details | Diff

  None (edit)
Description Richard D. Payne 2000-09-19 11:56:09 EDT
sndconfig reports that the ALi M5451 PCI South Bridge Audio is not
supported. However
support is provided by the trident audio driver in 2.2.16 and later. Here's
the entry from
/etc/sysconfig/hwconf

class: AUDIO
bus: PCI
detached: 0
driver: unknown
desc: "Acer Laboratories Inc. [ALi]|M5451 PCI South Bridge Audio"
vendorId: 10b9
deviceId: 5451
subVendorId: 10b9
subDeviceId: 5451
pciType: 1

This sould chip is included on the API UP1100 motherboard.
Comment 1 Richard D. Payne 2000-09-19 11:58:35 EDT
platform should be alpha
Comment 2 Richard D. Payne 2000-09-21 09:52:07 EDT
Created attachment 3483 [details]
Enable trident sound driver when CONFIG_ALPHA_GENERIC
Comment 3 Richard D. Payne 2000-09-21 09:52:55 EDT
I've attached a patch against 2.2.16-24 that enables the trident audio driver
whent he kernel
type is GENERIC, before this would only work is the kernel type was Nautilus.
Comment 4 Bill Nottingham 2000-10-19 01:38:17 EDT
Oops, we mapped the *other* version of the ALI bridge in
the pcitable. Fixed in CVS of kudzu, will be in next build.

Assigning to the kernel for the kernel patch.
Comment 5 Richard D. Payne 2000-10-19 08:02:35 EDT
FWIW, the patch has been accepted for 2.2.18.
Comment 6 Phil Copeland 2001-06-04 12:53:38 EDT
Is this issue still unresolved?
Comment 7 Richard D. Payne 2001-06-04 15:30:43 EDT
detection seems to be fixed with 7.1RC1.

Note You need to log in before you can comment on or make changes to this bug.