Bug 176955 - Service Profiles
Service Profiles
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-04 13:07 EST by Joseph Harnish
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-01 11:08:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Harnish 2006-01-04 13:07:11 EST
It would be great to have profile capabilities in system-config-services with
some default profiles already created.  IE

Laptop:
   NetworkManager
   NetworkManagerDispatcher
   mDNSResponder
   bluetooth
   etc,

Server:
   ntp
   http
   sshd
   etc

Workstation:
   cups
   
Low Resource Workstation:
   as little as possible to use X.

Thanks

Joe
Comment 1 Nils Philippsen 2007-02-01 11:08:22 EST
The plan for many services/daemons that currently are started at boot time is to
start them if neccessary, e.g. if HAL detects that certain hardware is
present/plugged in, if a network is accessible and so forth. This should make a
"Laptop" profile moot.

Since such profiles very likely won't completely describe what is wanted by the
user (not everybody wants to run httpd on their server), I don't think that this
is a desirable feature to have.

Note You need to log in before you can comment on or make changes to this bug.