Bug 176974 - Upgrade to current c-client version?
Upgrade to current c-client version?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libc-client (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-04 16:43 EST by Jonathan Kamens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2004g-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-05 10:29:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2006-01-04 16:43:55 EST
I've read bug 120873, and I understand why this RPM isn't going to be renamed 
and the server portion of it isn't going to be put back.  But is there any 
reason why we need to stick with a version of the c-client library that's over 
three years old?  The folks who maintain php-imap are certainly expecting a 
current version of the library, and surely changes have been made to it since 
2002.  So, if FC is going to continue to support the library for the sake of 
php-imap, then shouldn't the library RPM be updated to a current version?

In other words, I think I'm submitting a different bug from bug 120873, since 
that seemed to be about renaming the RPM and including support for building 
the server, and what I'm suggesting is leaving things as they are now but with 
a more recent version of the library.  If you disagree and think this is the 
same issue, feel free to close this ticket, but do please consider offering 
some explanation for why we should stick with a 3-year-old library :-).

Thanks.
Comment 1 Joe Orton 2006-01-05 05:26:42 EST
No, there's nothing preventing libc-client being updated to a newer version
other than lack of round tuits.  If you have some round tuits to use up and
submit patches here that would certainly be useful!
Comment 2 Jonathan Kamens 2006-01-05 09:48:23 EST
See http://stuff.mit.edu/~jik/libc-client-2004g-1.src.rpm.  I minimally tested 
php-imap with it, and it appears to work.  This is based on the most recent 
libc-client SRPM in FC devel.
Comment 3 Joe Orton 2006-01-05 10:29:53 EST
Thanks Jonathan.  I've built this in Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.