Bug 177018 - Unnecessary dependencies for sane-backends
Summary: Unnecessary dependencies for sane-backends
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: sane-backends   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-05 12:27 UTC by Tethys
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-14 15:43:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tethys 2006-01-05 12:27:23 UTC
Description of problem:

Having just done a yum update, I've had to install gphoto2 because the
latest version of sane-backends supports a gphoto2 backend. This is
wrong. If I don't plan on using that backend (which I don't), then I
shouldn't be forced to install a package that I don't want or need.
Is there *really* a dependency there? I.e., will sane applications not
work at all, even with a different backend if gphoto2 is not installed,
or will just that backend not work? If it's the former, then a serious
redesign is needed. Perhaps the gphoto2 backend could be split out
into a separate package. If it's the latter, then there shouldn't be
a dependency present.

For those of us trying to runa minimal system, dependency creep like
this is a real problem.

Version-Release number of selected component (if applicable):
sane-backends-1.0.17-0.fc4.1


How reproducible:
N/A

Steps to Reproduce:
1. N/A
2.
3.

Comment 1 Nils Philippsen 2006-03-14 15:43:25 UTC
The problem is that "soft dependencies" are not yet implemented in RPM (at least
for the version in FC4). So while the dependency on gphoto2 isn't strictly
necessary if you don't use that backend, it's the best we have, at least as long
as I don't split off backends into their own subpackages, which I don't want to do.

Paul, can you give some insight on RPM and soft dependencies, please?


Note You need to log in before you can comment on or make changes to this bug.