Bug 177028 - libdrm rpm has incorrect name and info
libdrm rpm has incorrect name and info
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libdrm (Show other bugs)
5
i386 Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-05 09:59 EST by David Timms
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: libdrm-2.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-16 15:00:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Timms 2006-01-05 09:59:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
libdrm should probably be called libdri.. looks like a typo and loss of plot during spec creation.

Version-Release number of selected component (if applicable):
libdrm-2.0-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -q --info libdrm-2.0-1.i386.rpm

Actual Results:  URL: http://dri.sourceforge.net
Summary: Digital Right Management library
Description:
 Digital Right Management runtime library

Expected Results:  libdri  

Direct Rendering Infrastructure library

The Direct Rendering Infrastructure, also known as the DRI, is a framework for allowing direct access to graphics hardware under the X Window System in a safe and efficient manner. It includes changes to the X server, to several client libraries, and to the kernel. The first major use for the DRI is to create fast OpenGL implementations.

The DRI is an integral part of XFree86 4.x , and integrates with Mesa, an open source implementation of the OpenGL API. Several 3D accelerated drivers have been written to the DRI specification, including drivers for chipsets produced by ATI, Matrox, 3DFX, and Intel.

Additional info:

rpm -e libdrm
  libdrm.so.2 is required by mesa-libGL-6.4.1-3.i386
  libdrm.so.2 is required by xorg-x11-drv-via-0.1.33.1-1.i386
so need to adjust these packages requires, and the resultant so name to match.
Comment 1 David Timms 2006-01-05 10:29:25 EST
Also noticed that the URL kicks the browser to:
http://dri.freedesktop.org/wiki/
Comment 2 Mike A. Harris 2006-01-09 17:13:45 EST
(In reply to comment #0)
> From Bugzilla Helper:
> User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923
Fedora/1.7.12-1.5.1
> 
> Description of problem:
> libdrm should probably be called libdri..

No, it is called libdrm by the DRI project, which is the correct name.

> looks like a typo and loss of plot during spec creation.

It's not a typo.  The authentic upstream source code can be found at:

    http://dri.freedesktop.org/libdrm

> Summary: Digital Right Management library
> Description:
>  Digital Right Management runtime library
   ^^^^^^^^^^^^^^^^^^^^^^^^

This however is simply a bit of humourous fun put into the developmental
packages as a temporary minor practical joke.  ;o)  It's got a few laughs
so far, but most people don't even notice it at all.  ;o)

 
> Expected Results:  libdri  

Which would be incorrect, as it is not libdri.

> Direct Rendering Infrastructure library
[SNIP]
> so need to adjust these packages requires, and the resultant so name to match.

Nope, just need to update the package Description and Summary to put the
correct information in it, thus ending the developmental humour.  That
will be in a future build prior to Fedora Core 5 release.

I'll update the report once it has been built.
Comment 3 Mike A. Harris 2006-01-16 15:00:27 EST
Fixed in libdrm-2.0-2

Note You need to log in before you can comment on or make changes to this bug.