This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 177060 - NetworkManager overrides user link speed setting.
NetworkManager overrides user link speed setting.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-05 16:05 EST by Andrew Overholt
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 17:46:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Overholt 2006-01-05 16:05:08 EST
Description of problem:
bcm43xx fails to associate with AP

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1819_FC5

How reproducible:
Always (for me).

Steps to Reproduce:
1. Attempt to associate with your WEP-enabled AP:
        ip link set eth0 up
        iwconfig eth0 enc your-wep-key-here
        iwconfig eth0 essid your-essid-here
2. dhclient eth0
  
Actual results:
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval {6, 10, ...}
SoftMAC:  Authentication timed out with <access point MAC>
SoftMAC: cannot associate without being authenticated, requested authentication

Expected results:
Association and DHCP lease acquisition.

Additional info:
Comment 1 Andrew Overholt 2006-01-05 16:40:48 EST
David Woodhouse suggested setting the rate to 11M.  This works for me if I am
using iwconfig.  NetworkManager seems to want to set the rate back to the
default (54M) no matter what I do.  Is this a NM bug or is there some way to
change the default?
Comment 2 Dave Jones 2006-01-06 17:30:36 EST
sounds like it.
The problems with 54M are known upstream, and will get worked out at some point.

regardless of whether 54M works though, NM shouldn't change the settings if the
user knows better than it does.
Comment 3 David Woodhouse 2006-01-06 17:46:56 EST
NM is a GNOME application. GNOME users aren't allowed to know better. Closing.
Comment 4 David Woodhouse 2006-03-22 11:02:43 EST
The bcm43xx driver in 2.6.16-1.2070_FC5 and later should default to 11M, even
when NetworkManager resets it. NetworkManager isn't setting the rate explicitly
to 54M; it's just resetting it to the driver's default.

Note You need to log in before you can comment on or make changes to this bug.