Bug 177065 - Ownership of texmf/doc
Ownership of texmf/doc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
https://www.redhat.com/archives/fedor...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-05 17:03 EST by Michael A. Peters
Modified: 2013-07-02 19:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-11 09:53:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael A. Peters 2006-01-05 17:03:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
RFE to change ownership of the texmf/doc package from tetex-doc to tetex

The issue is that Fedora Extras has changed policy such that packages are not allowed to own directories owned by other packages.

tetex packages often put stuff into texmf/doc so that they are available to the texdoc application, which is part of the tetex package.

Since the tetex-doc package owns texmf/doc but is rather large, and not required for texdoc to work - what we have been doing is allowing the various tetex add-on packages to own texmf/doc so that they don't result in an un-owned directory or have to require the huge tetex-doc package.

[mpeters@prometheus ~]$ rpm -qf /usr/share/texmf/doc
tetex-prosper-1.5-2.fc4
tetex-perltex-1.2-2.fc4
tetex-fontools-20051003-1.fc4
tetex-doc-3.0-7.FC4
[mpeters@prometheus ~]$ 

Since texdoc is owned by the tetex package and the texmf/doc directory is a standard place for tetex packages to put stuff, the simple solution would be to change ownership of the texmf/doc to the tetex package so that the tetex add-on packages no longer need to own that directory (or require tetex-doc)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. N/A
2.
3.
  

Additional info:

I don't think this is worth changing for FC 3/4 unless there is something else that needs changing, as the update would cause a massive download for a fairly trivial issue.

But if it could be resolved for fc5 it would allow tetex package in Extras for fc5 to follow the new packaging guidelines.
Comment 1 Jose Pedro Oliveira 2006-01-06 11:30:42 EST
(In reply to comment #0)
> From Bugzilla Helper:
> User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922
Fedora/1.0.7-1.1.fc4 Firefox/1.0.7
> 
> Description of problem:
> RFE to change ownership of the texmf/doc package from tetex-doc to tetex
> 
> The issue is that Fedora Extras has changed policy such that packages are not
allowed to own directories owned by other packages.
> 
> tetex packages often put stuff into texmf/doc so that they are available to
the texdoc application, which is part of the tetex package.
> 
> Since the tetex-doc package owns texmf/doc but is rather large, and not
required for texdoc to work - what we have been doing is allowing the various
tetex add-on packages to own texmf/doc so that they don't result in an un-owned
directory or have to require the huge tetex-doc package.
> 
> [mpeters@prometheus ~]$ rpm -qf /usr/share/texmf/doc
> tetex-prosper-1.5-2.fc4
> tetex-perltex-1.2-2.fc4
> tetex-fontools-20051003-1.fc4
> tetex-doc-3.0-7.FC4
> [mpeters@prometheus ~]$ 
> 
> Since texdoc is owned by the tetex package and the texmf/doc directory is a
standard place for tetex packages to put stuff, the simple solution would be to
change ownership of the texmf/doc to the tetex package so that the tetex add-on
packages no longer need to own that directory (or require tetex-doc)
> 

The ownership problem should also apply to every (?) texmf/doc subdirectory
  * /usr/share/texmf/doc/latex/    (latex packages documentation base dir)
  * /usr/share/texmf/doc/fonts/    (latex fonts documentation base dir)
  * /usr/share/texmf/doc/.../

just try a "rpm -qf /usr/share/texmf/doc/latex/"

> 
> Additional info:
> 
> I don't think this is worth changing for FC 3/4 unless there is something else
that needs changing, as the update would cause a massive download for a fairly
trivial issue.
> 

We do have a problem with current FC-4 and FC-5 tetex configuration: there is
no way to update system-wide latex core packages/fonts (the directory
search order is wrong):

   Command: kpsewhich -expand-var '$TEXMF'
   FC-3: {/root/texmf,!!/usr/local/share/texmf,!!/usr/share/texmf}
   FC-4: {!!/root/.texmf-config,!!/root/.texmf-var,/root/texmf, \
      !!/usr/share/texmf-config,!!/usr/share/texmf-var,!!/usr/share/texmf, \
      !!/usr/local/share/texmf,!!/usr/share/texmf-dist}
   Rawhide: {!!/root/.texmf-config,!!/root/.texmf-var,/root/texmf, \ 
      !!/usr/share/texmf-config,!!/usr/share/texmf-var,!!/usr/share/texmf, \ 
      !!/usr/local/share/texmf,!!/usr/share/texmf-dist}

In particular, the "/usr/local/share/texmf" directory should be listed before
 "/usr/share/texmf".

Note: at least the following packages - beamer, pgf, and xcolor - have more
recent versions than the ones shipped with tetex 3.0.
Comment 2 Jindrich Novy 2006-01-11 07:28:53 EST
There's no problem to move ownership for /usr/share/texmf/doc to tetex instead
of tetex-doc. I agree with this change, it looks reasonable. However I don't
think that even the subdirectories should be under the original tetex package.

I'll look at the directory priorities.
Comment 3 Jindrich Novy 2006-01-11 09:53:16 EST
/usr/share/texmf/doc now belongs to tetex package. TEXMFLOCAL is now searched 
before TEXMFMAIN.
Comment 4 Jindrich Novy 2006-01-12 05:06:22 EST
An update is comming soon to have it fixed in FC4 as well.

Note You need to log in before you can comment on or make changes to this bug.