Bug 177100 - attributes highlightinng offsets left by one symbol
attributes highlightinng offsets left by one symbol
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
: 177101 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-06 05:53 EST by Andy Shevchenko
Modified: 2013-07-02 19:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-16 07:13:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix it. (412 bytes, patch)
2006-01-06 07:15 EST, Jindrich Novy
no flags Details | Diff

  None (edit)
Description Andy Shevchenko 2006-01-06 05:53:07 EST
Description of problem:
Attributes and permissions of standart FS objects are not highlighting 
correctly.
For example, we have /bin directory with next attributes:
[andy@andriy Packages]$ ls -ld /bin
drwxr-xr-x  2 root root 4096 Янв  6 04:04 /bin

But I was logged as usual user. Hereby, mc highlights the last 'xr-' sequence.
It is wrong and should be 'r-x' from right of attributes string.

Version-Release number of selected component (if applicable):
Official FC4/FC3 versions (from updates).

How reproducible:
Just login as non-root user switch on the permission highlighting in the mc 
configuration and move cursor to a /bin directory for example.
Comment 1 Jindrich Novy 2006-01-06 06:44:55 EST
*** Bug 177101 has been marked as a duplicate of this bug. ***
Comment 2 Jindrich Novy 2006-01-06 07:15:56 EST
Created attachment 122868 [details]
Patch to fix it.

The fix is trivial. I'll send it to upstream as well since it's also affected.

Thanks,
Jindrich
Comment 3 Jindrich Novy 2006-01-06 07:33:03 EST
Patch sent upstream:
http://mail.gnome.org/archives/mc-devel/2006-January/msg00009.html
Comment 4 Andy Shevchenko 2006-01-06 07:57:19 EST
Thanks. I have no time to investigate problem.
Comment 5 Andy Shevchenko 2006-02-16 04:08:18 EST
With your patch I haven't described bug. Thank you for fix.

Note You need to log in before you can comment on or make changes to this bug.