Bug 17711 - error from Xsession script
Summary: error from Xsession script
Status: CLOSED DUPLICATE of bug 17580
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-19 16:34 UTC by Kevin Maguire
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 17:46:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin Maguire 2000-09-19 16:34:17 UTC
Hi

I noted an error in my .xsession-errors file.  It related to the following
section of /etc/X11/xdm/Xsession

% rpm -qf /etc/X11/xdm/Xsession
XFree86-3.3.6-20


if [ -z $XKB_IN_USE -a ! -L /etc/X11/X ]; then
 
For some reason this did not work, and generated an error about too many
arguments.  I simply replaced the "-a" with "&&" and the message went away.

Ciao
Kevin

Comment 1 Stephen Walton 2000-10-07 21:34:44 UTC
A previous bug report states that replacing $XKB_IN_USE with "$XKB_IN_USE" in
both places in Xsession where it appears in [] (lines 55 and 66) fixes the
problem.

Comment 2 Mike A. Harris 2001-03-10 06:13:45 UTC

*** This bug has been marked as a duplicate of 17580 ***


Note You need to log in before you can comment on or make changes to this bug.