Bug 177118 - Build requirements to xorg, libX and imake should be conditional
Summary: Build requirements to xorg, libX and imake should be conditional
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: groff   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-06 14:30 UTC by Robert Scheck
Modified: 2013-07-02 23:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 19:38:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff between groff spec files (962 bytes, patch)
2006-01-06 14:32 UTC, Robert Scheck
no flags Details | Diff

Description Robert Scheck 2006-01-06 14:30:22 UTC
Description of problem:
I think, the build requirements to xorg-*, libX* and imake should be
conditional for groff-gxditview, because groff also can be build with
%{with_x} 0 (which disables -gxditview).

Version-Release number of selected component (if applicable):
groff-1.18.1.1-6

Actual results:
Rebuilding with %{with_x} 0 isn't possible.

Expected results:
Rebuilding - the attached patch solves the problem for me.

Comment 1 Robert Scheck 2006-01-06 14:32:24 UTC
Created attachment 122874 [details]
Diff between groff spec files

Comment 2 Jindrich Novy 2006-01-06 19:38:31 UTC
Of course, thanks. It should be ok since 1.18.1.1-7.


Note You need to log in before you can comment on or make changes to this bug.