Bug 177118 - Build requirements to xorg, libX and imake should be conditional
Build requirements to xorg, libX and imake should be conditional
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: groff (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-06 09:30 EST by Robert Scheck
Modified: 2013-07-02 19:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 14:38:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff between groff spec files (962 bytes, patch)
2006-01-06 09:32 EST, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2006-01-06 09:30:22 EST
Description of problem:
I think, the build requirements to xorg-*, libX* and imake should be
conditional for groff-gxditview, because groff also can be build with
%{with_x} 0 (which disables -gxditview).

Version-Release number of selected component (if applicable):
groff-1.18.1.1-6

Actual results:
Rebuilding with %{with_x} 0 isn't possible.

Expected results:
Rebuilding - the attached patch solves the problem for me.
Comment 1 Robert Scheck 2006-01-06 09:32:24 EST
Created attachment 122874 [details]
Diff between groff spec files
Comment 2 Jindrich Novy 2006-01-06 14:38:31 EST
Of course, thanks. It should be ok since 1.18.1.1-7.

Note You need to log in before you can comment on or make changes to this bug.