Bug 17712 - XMMS hangs playing small files
Summary: XMMS hangs playing small files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xmms   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 16480 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-19 16:48 UTC by Tom Woller
Modified: 2014-03-17 02:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-19 16:48:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom Woller 2000-09-19 16:48:50 UTC
when the file size is less than the calculated prebuffer size, then the 
oss_loop() waits for data indefinitely.  modifying the code to set the 
prebuffer size to a limit of the file sample size fixes the problem on an 
ix86 platform. not much testing has occurred outside of the specific test 
set of .wav files (most of the .wav in the system sounds area).

patch for audio.c in xmms 1.2.3 pre:

--- Output/OSS/audio.c	Thu Sep 14 14:57:01 2000
+++ Output/OSS/audio.c.fix	Thu Sep 14 14:56:39 2000
@@ -396,6 +396,11 @@
 			off += cnt;
 
 		}
+		//
+		// eliminate hang in oss_loop when size of 
file<prebuffer_size
+		//
+		if(prebuffer_size > off)
+			prebuffer_size = off;
 	}
 	else
 	{

Comment 1 Bill Nottingham 2000-09-30 03:26:31 UTC
Fix will be added in the xmms-1.2.3-1 package. Thanks!

Comment 2 Bill Nottingham 2000-09-30 03:26:54 UTC
*** Bug 16480 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.