This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 177190 - Installing hal-0.5.5.1.cvs20060105-2, computer:/// does still monitor /etc/fstab
Installing hal-0.5.5.1.cvs20060105-2, computer:/// does still monitor /etc/...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-06 23:30 EST by sangu
Modified: 2013-03-13 00:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-10 12:46:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2006-01-06 23:30:31 EST
Description of problem:
hal-0.5.5.1.cvs20060105-2 make mount point to /etc/blkid.tab.
so, computer:// only has unmount medias.

Would computer:/// like to monitor /etc/mtab ?

Version-Release number of selected component (if applicable):
2.13.3-1

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 sangu 2006-01-06 23:32:14 EST
$ cat /etc/mtab
/dev/hda8 / ext3 rw 0 0
none /proc proc rw 0 0
none /sys sysfs rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
none /dev/shm tmpfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
/dev/hda5 /media/disk-1 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hda6 /media/disk-2 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb1 /media/disk-3 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb5 /media/disk-4 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb6 /media/disk-5 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb7 /media/disk-6 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb8 /media/disk-7 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb9 /media/disk-8 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0

$ cat /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/                 /                       ext3    defaults        1 1
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /sys                    sysfs   defaults        0 0
/dev/hda7               swap                    swap    defaults        0 0
/dev/hdb9               /media/idedisk          vfat    noauto,user,exec,utf8 0 0
/dev/hdb8               /media/idedisk1         vfat    noauto,user,exec,utf8 0 0
/dev/hdb7               /media/idedisk2         vfat    noauto,user,exec,utf8 0 0
/dev/hdb6               /media/idedisk3         vfat    noauto,user,exec,utf8 0 0
/dev/hdb5               /media/idedisk4         vfat    noauto,user,exec,utf8 0 0
/dev/hdb1               /media/idedisk5         vfat    noauto,user,exec,utf8 0 0
/dev/hda6               /media/idedisk6         vfat    noauto,user,exec,utf8 0 0
/dev/hda5               /media/idedisk7         vfat    noauto,user,exec,utf8 0 0
#/dev/hda1               /media/idedisk8         ntfs    noauto,user,exec,utf8 0 0
/dev/hdd                /media/cdrom            auto   
pamconsole,exec,noauto,managed 0 0
/dev/hdc                /media/cdrecorder       auto   
pamconsole,exec,noauto,managed 0 0

$ cat /etc/blkid.tab
<device DEVNO="0x0301" TIME="1087468899" TYPE="ntfs">/dev/hda1</device>
<device DEVNO="0x0305" TIME="1087468899" UUID="3027-139C"
TYPE="vfat">/dev/hda5</device>
<device DEVNO="0x0306" TIME="1087468899" UUID="E83B-EA5E"
TYPE="vfat">/dev/hda6</device>
<device DEVNO="0x0307" TIME="1136596422" TYPE="swap">/dev/hda7</device>
<device DEVNO="0x0308" TIME="1136596421" LABEL="/"
UUID="9d22b39b-65a5-446f-b26c-ce1e4f6ee401" SEC_TYPE="ext2"
TYPE="ext3">/dev/hda8</device>
<device DEVNO="0x0341" TIME="1087468899" UUID="2F53-1F08"
TYPE="vfat">/dev/hdb1</device>
<device DEVNO="0x0345" TIME="1087468899" UUID="277B-15D2"
TYPE="vfat">/dev/hdb5</device>
<device DEVNO="0x0346" TIME="1087468899" UUID="180A-401A"
TYPE="vfat">/dev/hdb6</device>
<device DEVNO="0x0347" TIME="1087468899" UUID="18D2-1949"
TYPE="vfat">/dev/hdb7</device>
<device DEVNO="0x0348" TIME="1087468899" UUID="18E0-3464"
TYPE="vfat">/dev/hdb8</device>
<device DEVNO="0x0349" TIME="1087468899" UUID="1502-211C"
TYPE="vfat">/dev/hdb9</device>

Comment 2 John (J5) Palmieri 2006-01-10 10:59:20 EST
Not sure what you mean.  It does monitor mtab.
Comment 3 sangu 2006-01-10 12:06:12 EST
computer:// Before restarting Messagebus
http://hellocity.net/~sangu/etc/hal/BeforeMessagebus.png
mount partions's icons display /etc/mtab.

computer:// after restaring messsagebus

http://hellocity.net/~sangu/etc/hal/AfterRestartingMessagebus.png

umount partions's icons display /etc/fstab.


Doing $killall gnome-vfs-daemon, computer:///
http://hellocity.net/~sangu/etc/hal/BeforeMessagebus.png

Doing $service messagebus restart

http://hellocity.net/~sangu/etc/hal/AfterRestartingMessagebus.png

$ cat /etc/mtab
/dev/hda8 / ext3 rw 0 0
none /proc proc rw 0 0
none /sys sysfs rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
none /dev/shm tmpfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
/dev/hda5 /media/disk-1 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hda6 /media/disk-2 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb1 /media/disk-3 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb5 /media/disk-4 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb6 /media/disk-5 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb7 /media/disk-6 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb8 /media/disk-7 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb9 /media/disk-8 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0

$ cat /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/                 /                       ext3    defaults        1 1
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /sys                    sysfs   defaults        0 0
/dev/hda7               swap                    swap    defaults        0 0
/dev/hdb9               /media/idedisk          vfat    noauto,user,exec,utf8 0 0
/dev/hdb8               /media/idedisk1         vfat    noauto,user,exec,utf8 0 0
/dev/hdb7               /media/idedisk2         vfat    noauto,user,exec,utf8 0 0
/dev/hdb6               /media/idedisk3         vfat    noauto,user,exec,utf8 0 0
/dev/hdb5               /media/idedisk4         vfat    noauto,user,exec,utf8 0 0
/dev/hdb1               /media/idedisk5         vfat    noauto,user,exec,utf8 0 0
/dev/hda6               /media/idedisk6         vfat    noauto,user,exec,utf8 0 0
/dev/hda5               /media/idedisk7         vfat    noauto,user,exec,utf8 0 0
/dev/hda1               /media/idedisk8         ntfs    noauto,user,exec,utf8 0 0
/dev/hdd                /media/cdrom            auto   
pamconsole,exec,noauto,managed 0 0
/dev/hdc                /media/cdrecorder       auto   
pamconsole,exec,noauto,managed 0 0

$ mount
/dev/hda8 on / type ext3 (rw)
none on /proc type proc (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
none on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/hda5 on /media/disk-1 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hda6 on /media/disk-2 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hdb1 on /media/disk-3 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hdb5 on /media/disk-4 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hdb6 on /media/disk-5 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hdb7 on /media/disk-6 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hdb8 on /media/disk-7 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hdb9 on /media/disk-8 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)

double clicking umounted icons in
http://hellocity.net/~sangu/etc/hal/AfterRestartingMessagebus.png
$ mount
/dev/hda8 on / type ext3 (rw)
none on /proc type proc (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
none on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/hda5 on /media/disk-1 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hda6 on /media/disk-2 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hdb1 on /media/disk-3 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hdb5 on /media/disk-4 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hdb6 on /media/disk-5 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hdb7 on /media/disk-6 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hdb8 on /media/disk-7 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hdb9 on /media/disk-8 type vfat
(rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501)
/dev/hdb8 on /media/idedisk1 type vfat (rw,nosuid,nodev,utf8,user=sangu)
/dev/hdb9 on /media/idedisk type vfat (rw,nosuid,nodev,utf8,user=sangu)
/dev/hdb7 on /media/idedisk2 type vfat (rw,nosuid,nodev,utf8,user=sangu)
/dev/hdb6 on /media/idedisk3 type vfat (rw,nosuid,nodev,utf8,user=sangu)
/dev/hdb5 on /media/idedisk4 type vfat (rw,nosuid,nodev,utf8,user=sangu)
/dev/hdb1 on /media/idedisk5 type vfat (rw,nosuid,nodev,utf8,user=sangu)
/dev/hda6 on /media/idedisk6 type vfat (rw,nosuid,nodev,utf8,user=sangu)
/dev/hda5 on /media/idedisk7 type vfat (rw,nosuid,nodev,utf8,user=sangu)

but umounted icons doesn't change computer://
http://hellocity.net/~sangu/etc/hal/AfterRestartingMessagebus.png
Comment 4 sangu 2006-01-10 12:07:20 EST
]$ cat /etc/mtab
/dev/hda8 / ext3 rw 0 0
none /proc proc rw 0 0
none /sys sysfs rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
none /dev/shm tmpfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
/dev/hda5 /media/disk-1 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hda6 /media/disk-2 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb1 /media/disk-3 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb5 /media/disk-4 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb6 /media/disk-5 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb7 /media/disk-6 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb8 /media/disk-7 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb9 /media/disk-8 vfat
rw,noexec,nosuid,nodev,quiet,shortname=winnt,uid=501 0 0
/dev/hdb8 /media/idedisk1 vfat rw,nosuid,nodev,utf8,user=sangu 0 0
/dev/hdb9 /media/idedisk vfat rw,nosuid,nodev,utf8,user=sangu 0 0
/dev/hdb7 /media/idedisk2 vfat rw,nosuid,nodev,utf8,user=sangu 0 0
/dev/hdb6 /media/idedisk3 vfat rw,nosuid,nodev,utf8,user=sangu 0 0
/dev/hdb5 /media/idedisk4 vfat rw,nosuid,nodev,utf8,user=sangu 0 0
/dev/hdb1 /media/idedisk5 vfat rw,nosuid,nodev,utf8,user=sangu 0 0
/dev/hda6 /media/idedisk6 vfat rw,nosuid,nodev,utf8,user=sangu 0 0
/dev/hda5 /media/idedisk7 vfat rw,nosuid,nodev,utf8,user=sangu 0 0
Comment 5 sangu 2006-01-10 12:12:04 EST
See also old bug 134781 :)
Comment 6 John (J5) Palmieri 2006-01-10 12:46:51 EST
Live restart of the messagebus is not supported.  You might want to file this
upstream so that gnome-vfs gracefully handles HAL going away.  Truth is if HAL
or the bus goes away it is a bad thing and you should reboot at that point. 
With the exception of development machines I have never exeperinced that
happening.  Closing this as not a bug.  I suggest moving this upstream and
refrencing this bug.

Note You need to log in before you can comment on or make changes to this bug.