Bug 177210 - eclipse doesn't start after update
eclipse doesn't start after update
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Igor Foox
:
: 182101 184009 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-07 11:05 EST by Dan Horak
Modified: 2007-11-30 17:11 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 10:34:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/etc/cron.daily/prelink (2.08 KB, text/plain)
2006-01-23 09:34 EST, Chris Savage
no flags Details

  None (edit)
Description Dan Horak 2006-01-07 11:05:56 EST
Description of problem:
After the current (Jan 7 2006) update of Eclipse it doesn't start.

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.1-1jpp_1fc.FC4.12

How reproducible:
start via menu or from terminal

Steps to Reproduce:
1. type "eclipse" in terminal
  
Actual results:
On the terminal I have "Failed to load Main-Class manifest attribute from
startup.jar" and a popup window with the following text apears:

JVM terminated. Exit code=1
/usr/bin/java
-jar startup.jar
-os linux
-ws gtk
-arch x86
-launcher /usr/bin/eclipse
-name Eclipse
-showsplash 600
-exitdata d8014
-vm /usr/bin/java
-vmargs
-jar startup.jar 

Expected results:
started Eclipse

Additional info:
I have deleted $HOME/.eclipse and $HOME/workspace/.*
Comment 1 Andrew Overholt 2006-01-07 14:10:32 EST
This is really bizarre.  We tested this a lot to make sure things still worked.  

Let's go through the basics:

rpm -q java-1.4.2-gcj-compat{,-devel} gcc gcc-java libgcj{,-devel}
rpm -qa | grep eclipse
which java
java -version
readlink -f `which java`
which eclipse
readlink -f `which eclipse`

Perhaps Igor will have some other ideas.
Comment 2 Dan Horak 2006-01-07 14:19:09 EST
Here it is (up-to-date FC4 + some packages from Extras, RPMforge and Freshrpms):

[dan@certp ~]$ rpm -q java-1.4.2-gcj-compat{,-devel} gcc gcc-java libgcj{,-devel}
java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.2
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_31rh.FC4.2
gcc-4.0.2-8.fc4
gcc-java-4.0.2-8.fc4
libgcj-4.0.2-8.fc4
libgcj-devel-4.0.2-8.fc4

[dan@certp ~]$ rpm -qa | grep eclipse
eclipse-cdt-3.0.0_fc-1.FC4
eclipse-jdt-3.1.1-1jpp_1fc.FC4.12
eclipse-pde-3.1.1-1jpp_1fc.FC4.12
eclipse-rcp-3.1.1-1jpp_1fc.FC4.12
eclipse-platform-3.1.1-1jpp_1fc.FC4.12
eclipse-platform-devel-3.1.1-1jpp_1fc.FC4.12
eclipse-changelog-2.0.1_fc-21
eclipse-pydev-0.9.3_fc-7
eclipse-rcp-devel-3.1.1-1jpp_1fc.FC4.12
eclipse-bugzilla-0.1.0_fc-16
eclipse-ecj-3.1.1-1jpp_1fc.FC4.12
eclipse-jdt-devel-3.1.1-1jpp_1fc.FC4.12

[dan@certp ~]$ which java
/usr/bin/java
[dan@certp ~]$ java -version
java version "1.4.2"
gij (GNU libgcj) version 4.0.2 20051125 (Red Hat 4.0.2-8)

Copyright (C) 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
[dan@certp ~]$ readlink -f `which java`
/usr/bin/gij
[dan@certp ~]$ which eclipse
/usr/bin/eclipse
[dan@certp ~]$ readlink -f `which eclipse`
/usr/bin/eclipse
Comment 3 Dan Horak 2006-01-07 14:20:34 EST
I will update my other system on Monday, so I can compare their behaviour.
Comment 4 Andrew Overholt 2006-01-07 14:22:13 EST
Wow, I just tried this myself on another i386 machine and I can duplicate.  The
problem is that /usr/bin/eclipse isn't a symlink to /usr/share/eclipse/eclipse
as it should be.  A temporary workaround is:

cd /usr/bin
sudo rm eclipse
sudo ln -s /usr/share/eclipse/eclipse

I wonder if something happened in the rpm upgrade process that messed up the
symlink ... but we tested that so how could that have happened?

I just extracted what's in the RPM itself using rpm2cpio and /usr/bin/eclipse is
indeed a symlink.  I have no idea what's going on here.

Tom, I know you've dealt with non-symlink -> symlink issues before.  Can you
shed any light here?
Comment 5 Dan Horak 2006-01-08 06:36:50 EST
The last command should be
sudo ln -s /usr/share/eclipse/eclipse eclipse

and it works now.
Comment 6 Patrick 2006-01-08 11:14:19 EST
I had the same issue. System is an x86_64 laptop (Acer Ferrari 4005) with FC4
workstation install + a few tidbits, yum update afterwards and yum update
yesterday which installed the new Eclipse. Eclipse would not startup afterwards
with the same message reported by Dan. Today I found this bugreport and tried
the symlink trick. Now  Eclipse starts up fine. Here's the info you requested:

rpm -q java-1.4.2-gcj-compat{,-devel} gcc gcc-java libgcj{,-devel}

java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.2
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_31rh.FC4.2
gcc-4.0.2-8.fc4
gcc-java-4.0.2-8.fc4
libgcj-4.0.2-8.fc4
libgcj-4.0.2-8.fc4
libgcj-devel-4.0.2-8.fc4

rpm -qa | grep eclipse
eclipse-bugzilla-0.1.0_fc-16
eclipse-pde-3.1.1-1jpp_1fc.FC4.12
eclipse-jdt-devel-3.1.1-1jpp_1fc.FC4.12
eclipse-platform-devel-3.1.1-1jpp_1fc.FC4.12
eclipse-ecj-3.1.1-1jpp_1fc.FC4.12
eclipse-jdt-3.1.1-1jpp_1fc.FC4.12
eclipse-pde-devel-3.1.1-1jpp_1fc.FC4.12
eclipse-changelog-2.0.1_fc-21
eclipse-rcp-devel-3.1.1-1jpp_1fc.FC4.12
eclipse-platform-3.1.1-1jpp_1fc.FC4.12
eclipse-pydev-0.9.3_fc-7
eclipse-cdt-3.0.0_fc-1.FC4
eclipse-rcp-3.1.1-1jpp_1fc.FC4.12

which java
/usr/bin/java

java -version
java version "1.4.2"
gij (GNU libgcj) version 4.0.2 20051125 (Red Hat 4.0.2-8)

Copyright (C) 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

readlink -f `which java`
/usr/bin/gij

which eclipse
/usr/bin/eclipse

readlink -f `which eclipse`
/usr/bin/eclipse

Please let me know if you need more info. Be happy to get it for you.
Comment 7 Dan Horak 2006-01-08 17:06:08 EST
I really do not understand - I have just updated my other machine from the same
packages (they were copied from my notebook to my desktop) and /usr/bin/eclipse
is the correct symlink to /usr/share/eclipse/eclipse and Eclipse is working as
expected.
Comment 8 Patrick 2006-01-10 11:04:33 EST
Re comment #6: this is puzzling. Now it won't start anymore:

$ eclipse
Failed to load Main-Class manifest attribute from startup.jar

$ rm -rf ~/workspace
$ rm -rf .eclipse
$ eclipse

Gives the same error.

Oh wait:
$ ll /usr/bin/eclipse
-rwxr-xr-x 2 root root  25928 Jan    5 18:41 /usr/bin/eclipse

Wasn't that supposed to be a symlink?

$ sudo mv /usr/bin/eclipse /usr/bin/eclipse.org
$ sudo ln -s /usr/share/eclipse/eclipse /usr/bin/eclipse
$ eclipse

Now it starts somewhat... It fails after the initial "Fedora Eclipse based on
Eclipse 3.1.1" window pops up and in the lower part the progress bar almost hits
the right end. It freezes and a gtk2 error window pops up with the following text:

JVM terminated. Exit code=1
/usr/bin/java
-jar startup.jar
-os linux
-ws gtk
-arch x86_64
-launcher /usr/bin/eclipse
-name Eclipse
-showsplash 600
-exitdata f0015
-vm /usr/bin/java
-vmargs
-jar startup.jar 
Comment 9 Patrick 2006-01-10 11:19:49 EST
Did some more fiddling around. Here's a weird one:
$ rm -rf ~/workspace
$ rm -rf ~/.eclipse
$ eclipse
Pressed "OK" when asked to select a workspace (/home/patrick/workspace). It
fails again and the splashscreen is still visible on screen (to remove it I
would have to $ killall eclipse). I leave the splashscreen alone and run eclipse
again:
$ eclipse
It uses the same hanging splashscreen, asks me for a workspace (I again select
the offered /home/patrick/workspace by cliking "OK"). Note that during the first
attempt to start eclipse /home/patrick/workspace was already created. Now
eclipse starts. The splashscreen is still visible/active. When I exit eclipse it
exits ok but the splashscreen is still there so I need to killall eclipse.
Comment 10 Patrick 2006-01-10 11:33:41 EST
The suggestion in https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=174612#c7
fixed the issue for me. Eclipse now starts fine. An update for FC4 of
java-1.4.2-gcj-compat to java-1.4.2-gcj-compat-1.4.2.0-40jpp_59rh.FC4.2 would be
nice (if possible).
Comment 11 Dan Horak 2006-01-10 12:22:03 EST
(In reply to comment #7)
> I really do not understand - I have just updated my other machine from the same
> packages (they were copied from my notebook to my desktop) and /usr/bin/eclipse
> is the correct symlink to /usr/share/eclipse/eclipse and Eclipse is working as
> expected.

This was just after doing the update. Now the situation is the same =
/usr/bin/eclipse is not a symlink. Could not ld-prelink be the cause?
Comment 12 Andrew Overholt 2006-01-10 14:59:07 EST
Weird.  I was just speaking with Jeremy Katz about this and he said he's never
seen anything like it.  It's obviously somewhat reproduceable if the three of us
did it at least once.  What versions of yum and rpm do you guys have?

I have:

rpm-4.4.1-22
yum-2.4.1-1.fc4

which I think are the latest in fc4-updates.
Comment 13 Dan Horak 2006-01-10 15:23:36 EST
I have:

rpm-4.4.1-22
yum-2.4.1-1.fc4

It is probably not related to rpm or yum, because as you can see in my comments
#7 and #11, just after running yum update (and installing the rpms) it was OK
(on sunday night), but after starting the desktop today (tuesday) it is KO.
Don't know about the situation on monday as I have not tried to start Eclipse.
Also the double-symlink is not a usual thing, I would say. I will wait a few
days and will see if anything goes wrong again.
Comment 14 Patrick 2006-01-11 06:35:09 EST
I have:

rpm-4.4.1-22
yum-2.4.1-1.fc4
Comment 15 Tim Lauridsen 2006-01-12 05:23:22 EST
I Had the same problem, when i updates, Eclipse 3.1.1 was working, but after a
reboot, i couldn't start Eclipse.

#yum remove eclipse-platform eclipse-pydev
#rm -rf ~/workplace/.metadata
#rm -rf .eclipse
#yum install eclipse-platform eclipse-pydev

Now it was working again.

I am running a FC4 with all current updates.
Comment 16 Gustavo Maciel Dias Vieira 2006-01-12 15:37:46 EST
Got the same problem here. Reinstalling makes it work until the next reboot.
Comment 17 Tim Lauridsen 2006-01-13 02:38:38 EST
(In reply to comment #16)
> Got the same problem here. Reinstalling makes it work until the next reboot.
> 
The same here after reboot it is not working again ..

#eclipse (not working)
#which eclipse
/usr/bin/eclipse
(/usr/bin/eclipse is not a symlink)
#/usr/share/eclipse/eclipse (this is working)

#cd /usr/bin
#sudo rm eclipse
#sudo ln -s /usr/share/eclipse/eclipse

Now it is working again 
Comment 18 GeneD 2006-01-13 19:08:33 EST
Hi,,
I am experiencing the same on two machines, except for I do not reboot. I would
uninstall eclipse-platform, and eclipse-pydev and then reinstall them and they
would world until the next day at work or home. 
I just uninstalled eclipse and then reinstalled it it, it worked. So i shut it
down and then started it again it worked. 
I then ran as root run-parts /etc/cron.daily and tried to start eclipse. it did
not work. something in cron.daily is messing it up. 

ls -al /etc/cron.daily/
total 84
drwxr-xr-x   2 root root  4096 Jan 10 17:08 .
drwxr-xr-x  86 root root 12288 Jan 13 17:06 ..
-rwxr-xr-x   1 root root   276 Mar 16  2005 0anacron
lrwxrwxrwx   1 root root    39 Oct 30 10:49 0logwatch ->
/usr/share/logwatch/scripts/logwatch.pl
-rwxr-xr-x   1 root root   118 Jan  4 11:39 cups
-rwxr-xr-x   1 root root   180 Mar 31  2005 logrotate
-rwxr-xr-x   1 root root   418 Apr  8  2005 makewhatis.cron
-rwxr-xr-x   1 root root  2133 Nov 23  2004 prelink
-rwxr-xr-x   1 root root   104 Jul 13  2005 rpm
-rwxr-xr-x   1 root root   246 Aug  9 16:00 slocate.cron
-rwxr-xr-x   1 root root   100 Dec  7 03:32 tetex.cron
-rwxr-xr-x   1 root root   286 Apr 16  2005 tmpwatch
-rwxr-xr-x   1 root root   158 Dec  5 09:09 yum.cron
Comment 19 GeneD 2006-01-13 21:57:37 EST
Update:
I went through the remove/install of eclipse-platform again. It worked as
expected after the reinstall. I ran just prelink in /etc/cron.daily/ and tried
to start eclipse again. Eclipse did not start up.

I wonder what changed in eclipse the last update that prelink would mess up.

Comment 20 Weiqi Gao 2006-01-14 12:09:55 EST
Just a "me too" post.  I have a default FC4 x86_64 install with daily yum update
turned on.  I was hit by the bug (I don't run Eclipse every day), searched the
bugzilla which lead me here.  The symlink fixed problem.  Thanks.
Comment 21 GeneD 2006-01-14 14:44:18 EST
Here is what is happening:

Working eclipse:
[root@localhost ~]# ls -al /usr/bin/eclipse
lrwxrwxrwx  1 root root 26 Jan 14 09:05 /usr/bin/eclipse ->
/usr/share/eclipse/eclipse

Run prelink
[root@localhost ~]# /etc/cron.daily/prelink

Non-Working eclipse:
[root@localhost ~]# ls -al /usr/bin/eclipse
-rwxr-xr-x  2 root root 20256 Jan  5 10:33 /usr/bin/eclipse

Comment 22 Tim Lauridsen 2006-01-15 04:11:57 EST
I dont know if it mean anything, but i have look at the spec file to see if
count find somethine.

I looks like the real binary are located in /usr/lib/eclipse/eclipse

The link chain:
/usr/bin/eclipse -> /usr/share/eclipse/eclipse -> /usr/lib/eclipse/eclipse

Maybe it should be something like this.
/usr/bin/eclipse -> /usr/lib/eclipse/eclipse
/usr/share/eclipse/eclipse -> /usr/lib/eclipse/eclipse

I don't now if it mean something, just a wild guess.

On my rawhide machine, i dont have any problems.

[tim@localhost ~]$ rpm -q eclipse-platform
eclipse-platform-3.1.1-1jpp_15fc
[tim@localhost ~]$ rpm -q prelink
prelink-0.3.6-2




Comment 23 Igor Foox 2006-01-16 10:58:42 EST
(In reply to comment #21)
> Here is what is happening:
> 
> Working eclipse:
> [root@localhost ~]# ls -al /usr/bin/eclipse
> lrwxrwxrwx  1 root root 26 Jan 14 09:05 /usr/bin/eclipse ->
> /usr/share/eclipse/eclipse
> 
> Run prelink
> [root@localhost ~]# /etc/cron.daily/prelink
> 
> Non-Working eclipse:
> [root@localhost ~]# ls -al /usr/bin/eclipse
> -rwxr-xr-x  2 root root 20256 Jan  5 10:33 /usr/bin/eclipse

Hi Gene, could you attach your /etc/cron.daily script so I can check if it's the
same as what I have. I haven't yet been able to reproduce this.
Comment 24 Jeroen Beerstra 2006-01-16 15:04:04 EST
Same here (FC4 x86_64).

After the upgrade eclipse works just fine, after the first reboot it refuses to
run. Restoring the symlink /usr/bin/eclipse does the trick.

For now I just put "-b /usr/bin/eclipse" in /etc/prelink.conf, before "-l
/usr/bin " that is.

Is this perhaps the reason prelink suddenly started to mess up eclipse:

"Also, all jars are now natively-compiled and thanks to the
latest release of gjdoc, all of the API documentation is now
built."


 
Comment 25 GeneD 2006-01-17 20:51:47 EST
Sorry, I have tried for the last couple of days to get it to break again but I
can not. 
I upgraded the kernel on my machine to .1656, and rebooted and I have not been
able to reproduce the problem. I booted my old kernel and it still did not show
up. I had not rebooted the machine for a couple of months. 
Comment 26 Chris Savage 2006-01-23 09:34:18 EST
Created attachment 123574 [details]
/etc/cron.daily/prelink
Comment 27 Chris Savage 2006-01-23 09:36:53 EST
/etc/cron.daily/prelink script. It is definately the prelink cron job that is
killing it on here, I ran "prelink -n -v -a" with the following output:

> Prelinking /usr/bin/eclipse
> Linking /usr/lib/eclipse/eclipse to /usr/bin/eclipse
> /usr/sbin/prelink: /usr/lib/eclipse/eclipse is no longer hardlink to >
/usr/bin/eclipse

Should it not link to /usr/share/eclipse/eclipse? I do not know enough about
prelink to suggest a fix or why it's going wrong.
Comment 28 Larry Sturtz 2006-01-24 08:19:07 EST
Here's a curve.  I have installed sun java 5.0 and eclipse was working fine
until the update.  After reboot, same error as above.  Changing /usr/bin/eclipse
to symlink gets by the first error, shows eclipse splash screen, then the very
informative error: "Error  An error has occurred. See the log file
<$HOME>/workspace/.metadata/.log", which has 1006 lines in it.

But if I su - in a term window and type eclipse.  It works just fine. 
Permissions?  difference in root PATH?
Comment 29 Gustavo Maciel Dias Vieira 2006-01-24 08:40:30 EST
(In reply to comment #28)
> "Error  An error has occurred. See the log file
> <$HOME>/workspace/.metadata/.log"

I've seen it but I believe it's not related. Just remove the files
~/.eclipse/org.eclipse.platform* and try again.
Comment 30 Larry Sturtz 2006-01-24 09:16:53 EST
Gustavo,
Well, yeah!  That worked!  I have my eclipse/Java 5.0 back.  It recreated
.eclipse/org.eclipse.platform_3.1.1.

So what happened?  And thanks alot!
Comment 31 Igor Foox 2006-01-25 10:12:35 EST
I have finally been able to reproduce the problem (after many many trials). A
definite way to reproduce it (on this computer) is to yum install eclipse
packages. Then run 'sudo /etc/cron.daily/prelink'. After this /usr/bin/eclipse
is not a symlink. If I symlink it correctly and rerun prelink it does not affect
it. Removing and reinstalling the eclipse packages and rerunning prelink
reproduces the problem.

I'll investigate some more.
Comment 32 Jonathan Ryshpan 2006-01-25 21:12:31 EST
I have the same problem.  On my system eclipse is a symlink:
$ ls -l /usr/bin/eclipse
lrwxrwxrwx  1 root root 26 Jan 25 12:07 /usr/bin/eclipse ->
/usr/share/eclipse/eclipse*

Here is my system info:
$ uname -a
Linux claremont.localdomain 2.6.14-1.1656_FC4 #1 Thu Jan 5 22:13:55 EST 2006
x86_64 x86_64 x86_64 GNU/
Linux
$ which java
/usr/java/jre1.5.0_01/bin/java
$ java -version
java version "1.5.0_01"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_01-b08)
Java HotSpot(TM) Client VM (build 1.5.0_01-b08, mixed mode, sharing)
$ rpm -q '--queryformat=%{name}-%{version}-%{release}.%{arch}' gcc gcc-java
java-1.4.2-gcj-compat java
-1.4.2-gcj-compat-devel eclipse-platform
gcc-4.0.2-8.fc4.x86_64gcc-java-4.0.2-8.fc4.x86_64java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.2.x86_64
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_31rh.FC4.2.x86_64eclipse-platform-3.1.1-1jpp_1fc.FC4.12.x86_
64
Comment 33 Stephen John Smoogen 2006-01-30 20:30:29 EST
Ran into this problem on an existing machine. Went through the usual list with a
copy of my normal user.
  Remove workspace
  Remove .eclipse
  Removed eclipse and particular packages.
  Installed eclipse (yum install eclipse)
Found this bug report and followed the link issue. This fixed some problems but
gave an error about various jar nots being. This looks to be an rpm dependency
issue. A yum install eclipse installed:

eclipse-ecj-3.1.1-1jpp_1fc.FC4.12
eclipse-rcp-3.1.1-1jpp_1fc.FC4.12
eclipse-platform-3.1.1-1jpp_1fc.FC4.12

I needed to install pretty much every eclipse rpm to get eclipse to work again.

Installed fresh system in vmaware
Ran updates to get latest updates.
Eclipse fails to run as listed due to broken prelinked binary

Made the symbolic link as appropriate and system worked. Put in the -b line and
things seem not to get broken again..

I think that covers all the problems people are seeing with explanations:

A) eclipse needs more Requires to get working
B) prelink is breaking eclipse.
Comment 34 Andrew Overholt 2006-02-03 11:49:34 EST
(In reply to comment #33)
> A yum install eclipse installed:
> 
> eclipse-ecj-3.1.1-1jpp_1fc.FC4.12
> eclipse-rcp-3.1.1-1jpp_1fc.FC4.12
> eclipse-platform-3.1.1-1jpp_1fc.FC4.12

Can you paste the output of "yum install eclipse"?  I never do this so I don't
know what it does.  I'm 99.9% sure we have all of the proper Requires set up. 
Platform should requires rcp and libswt so I'm surprised libswt wasn't
installed.  Assuming it was and you just missed it, things *should* have run. 
I've tested that configuration (just platform + deps) a few times and it has
always worked for me.  Is this with gij?
Comment 35 Stephen John Smoogen 2006-02-04 13:05:44 EST
Steps to try and reproduce:

yum remove eclipse*
Removed: eclipse-bugzilla.i386 1:0.1.0_fc-16 eclipse-cdt.i386 1:3.0.0_fc-1.FC4
eclipse-changelog.i386 1:2.0.1_fc-21 eclipse-ecj.i386 1:3.1.1-1jpp_1fc.FC4.12
eclipse-jdt.i386 1:3.1.1-1jpp_1fc.FC4.12 eclipse-jdt-devel.i386
1:3.1.1-1jpp_1fc.FC4.12 eclipse-pde.i386 1:3.1.1-1jpp_1fc.FC4.12
eclipse-platform.i386 1:3.1.1-1jpp_1fc.FC4.12 eclipse-platform-devel.i386
1:3.1.1-1jpp_1fc.FC4.12 eclipse-pydev.i386 1:0.9.3_fc-7 eclipse-rcp.i386
1:3.1.1-1jpp_1fc.FC4.12 eclipse-rcp-devel.i386 1:3.1.1-1jpp_1fc.FC4.12
Dependency Removed: ant.i386 0:1.6.2-3jpp_8fc ant-antlr.i386 0:1.6.2-3jpp_8fc
ant-apache-bcel.i386 0:1.6.2-3jpp_8fc ant-apache-log4j.i386 0:1.6.2-3jpp_8fc
ant-apache-oro.i386 0:1.6.2-3jpp_8fc ant-apache-regexp.i386 0:1.6.2-3jpp_8fc
ant-apache-resolver.i386 0:1.6.2-3jpp_8fc ant-commons-logging.i386
0:1.6.2-3jpp_8fc ant-javamail.i386 0:1.6.2-3jpp_8fc ant-jdepend.i386
0:1.6.2-3jpp_8fc ant-jmf.i386 0:1.6.2-3jpp_8fc ant-jsch.i386 0:1.6.2-3jpp_8fc
ant-junit.i386 0:1.6.2-3jpp_8fc ant-nodeps.i386 0:1.6.2-3jpp_8fc ant-swing.i386
0:1.6.2-3jpp_8fc ant-trax.i386 0:1.6.2-3jpp_8fc java-1.4.2-gcj-compat-devel.i386
0:1.4.2.0-40jpp_31rh.FC4.2 tomcat5.i386 0:5.0.30-5jpp_6fc tomcat5-jasper.i386
0:5.0.30-5jpp_6fc

yum install eclipse

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 eclipse-platform        i386       1:3.1.1-1jpp_1fc.FC4.12  updates-released 56 M
Installing for dependencies:
 ant                     i386       1.6.2-3jpp_8fc   base              2.0 M
 ant-antlr               i386       1.6.2-3jpp_8fc   base               20 k
 ant-apache-bcel         i386       1.6.2-3jpp_8fc   base               23 k
 ant-apache-log4j        i386       1.6.2-3jpp_8fc   base               18 k
 ant-apache-oro          i386       1.6.2-3jpp_8fc   base               61 k
 ant-apache-regexp       i386       1.6.2-3jpp_8fc   base               19 k
 ant-apache-resolver     i386       1.6.2-3jpp_8fc   base               19 k
 ant-commons-logging     i386       1.6.2-3jpp_8fc   base               19 k
 ant-javamail            i386       1.6.2-3jpp_8fc   base               21 k
 ant-jdepend             i386       1.6.2-3jpp_8fc   base               27 k
 ant-jmf                 i386       1.6.2-3jpp_8fc   base               16 k
 ant-jsch                i386       1.6.2-3jpp_8fc   base               36 k
 ant-junit               i386       1.6.2-3jpp_8fc   base               88 k
 ant-nodeps              i386       1.6.2-3jpp_8fc   base              381 k
 ant-swing               i386       1.6.2-3jpp_8fc   base               18 k
 ant-trax                i386       1.6.2-3jpp_8fc   base               87 k
 eclipse-ecj             i386       1:3.1.1-1jpp_1fc.FC4.12  updates-released  6.9 M
 eclipse-rcp             i386       1:3.1.1-1jpp_1fc.FC4.12  updates-released 43 k
 java-1.4.2-gcj-compat-devel  i386       1.4.2.0-40jpp_31rh.FC4.2 
updates-released   19 k
 tomcat5                 i386       5.0.30-5jpp_6fc  base              3.5 M
 tomcat5-jasper          i386       5.0.30-5jpp_6fc  base              970 k

Transaction Summary
=============================================================================
Install     22 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
Total download size: 70 M
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction

Eclipse gives a long error list at this point

!SESSION 2006-02-04 11:07:00.733 -----------------------------------------------
eclipse.buildId=M20050929-0840
java.fullversion=GNU libgcj 4.0.2 20051125 (Red Hat 4.0.2-8)
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86

!ENTRY org.eclipse.core.runtime 2006-02-04 11:07:02.244
!MESSAGE Product org.eclipse.sdk.ide could not be found.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.248
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
   at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(java.lang.Object)
(/usr/lib/gcj/eclipse/org.eclipse.core.runtime_3.1.1.jar.so)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(java.lang.Object)
(/usr/lib/gcj/eclipse/org.eclipse.osgi_3.1.1.jar.so)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(java.lang.String[],
java.lang.Runnable) (/usr/lib/gcj/eclipse/org.eclipse.osgi_3.1.1.jar.so)
   at java.lang.reflect.Method.invoke(java.lang.Object, java.lang.Object[])
(/usr/lib/libgcj.so.6.0.0)
   at org.eclipse.core.launcher.Main.invokeFramework(java.lang.String[],
java.net.URL[]) (/usr/lib/gcj/eclipse/startup.jar.so)
   at org.eclipse.core.launcher.Main.basicRun(java.lang.String[])
(/usr/lib/gcj/eclipse/startup.jar.so)
   at org.eclipse.core.launcher.Main.run(java.lang.String[])
(/usr/lib/gcj/eclipse/startup.jar.so)
   at org.eclipse.core.launcher.Main.main(java.lang.String[])
(/usr/lib/gcj/eclipse/startup.jar.so)
   at gnu.java.lang.MainThread.call_main() (/usr/lib/libgcj.so.6.0.0)
   at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.294
!MESSAGE Bundle update@plugins/org.eclipse.ui.workbench_3.1.1.jar [3] was not
resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.294
!MESSAGE Missing required bundle org.eclipse.jface_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.294
!MESSAGE Bundle update@plugins/org.eclipse.ui.editors_3.1.1.jar [4] was not
resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.295
!MESSAGE Missing required bundle org.eclipse.ui.ide_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.295
!MESSAGE Missing required bundle org.eclipse.ui.workbench.texteditor_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.295
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.295
!MESSAGE Missing required bundle org.eclipse.jface.text_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.295
!MESSAGE Bundle update@plugins/org.eclipse.compare_3.1.1.jar [6] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.295
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.295
!MESSAGE Missing required bundle org.eclipse.jface.text_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.295
!MESSAGE Missing required bundle org.eclipse.ui.ide_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.296
!MESSAGE Missing required bundle org.eclipse.ui.views_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.296
!MESSAGE Missing required bundle org.eclipse.ui.workbench.texteditor_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.296
!MESSAGE Bundle update@plugins/org.eclipse.help.ui_3.1.1.jar [8] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.296
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.296
!MESSAGE Missing required bundle org.eclipse.ui.forms_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.296
!MESSAGE Bundle update@plugins/org.eclipse.ltk.ui.refactoring_3.1.1.jar [9] was
not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.296
!MESSAGE Missing required bundle org.eclipse.jface.text_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.296
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.297
!MESSAGE Missing required bundle org.eclipse.compare_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.297
!MESSAGE Missing required bundle org.eclipse.ui.workbench.texteditor_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.297
!MESSAGE Bundle update@plugins/org.eclipse.ui.views_3.1.1.jar [10] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.297
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.297
!MESSAGE Bundle update@plugins/org.eclipse.debug.ui_3.1.1.jar [11] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.297
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.297
!MESSAGE Missing required bundle org.eclipse.ui.console_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.298
!MESSAGE Missing required bundle org.eclipse.jface.text_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.298
!MESSAGE Missing required bundle org.eclipse.ui.workbench.texteditor_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.298
!MESSAGE Missing required bundle org.eclipse.ui.ide_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.298
!MESSAGE Missing required bundle org.eclipse.ui.editors_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.298
!MESSAGE Bundle update@plugins/org.eclipse.ui.cheatsheets_3.1.1.jar [18] was not
resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.298
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.298
!MESSAGE Missing required bundle org.eclipse.ui.forms_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.299
!MESSAGE Bundle update@plugins/org.eclipse.ui.workbench.texteditor_3.1.1.jar
[19] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.299
!MESSAGE Missing required bundle org.eclipse.jface.text_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.299
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.299
!MESSAGE Bundle update@plugins/org.eclipse.update.ui_3.1.1.jar [21] was not
resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.299
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.299
!MESSAGE Missing required bundle org.eclipse.ui.forms_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.300
!MESSAGE Bundle update@plugins/org.eclipse.ant.ui_3.1.1.jar [23] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.300
!MESSAGE Missing optionally required bundle org.eclipse.ui.ide_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.300
!MESSAGE Missing optionally required bundle org.eclipse.ui.views_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.300
!MESSAGE Missing optionally required bundle org.eclipse.jface.text_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.300
!MESSAGE Missing optionally required bundle
org.eclipse.ui.workbench.texteditor_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.300
!MESSAGE Missing optionally required bundle org.eclipse.ui.editors_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.300
!MESSAGE Missing required bundle org.eclipse.ui.externaltools_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.300
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.300
!MESSAGE Missing required bundle org.eclipse.ui.console_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.300
!MESSAGE Missing required bundle org.eclipse.debug.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.300
!MESSAGE Missing required bundle org.eclipse.jdt.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.300
!MESSAGE Missing required bundle org.eclipse.jdt.debug.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.301
!MESSAGE Missing required bundle org.eclipse.jdt.launching_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.301
!MESSAGE Bundle update@plugins/org.eclipse.ui_3.1.1.jar [24] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.301
!MESSAGE Missing required bundle org.eclipse.jface_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.301
!MESSAGE Missing required bundle org.eclipse.ui.workbench_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.302
!MESSAGE Bundle update@plugins/org.eclipse.ui.browser_3.1.1.jar [31] was not
resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.302
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.302
!MESSAGE Bundle update@plugins/org.eclipse.ui.console_3.1.0.jar [33] was not
resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.302
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.302
!MESSAGE Missing required bundle org.eclipse.jface.text_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.302
!MESSAGE Missing required bundle org.eclipse.ui.workbench.texteditor_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.303
!MESSAGE Bundle update@plugins/org.eclipse.update.scheduler_3.1.0.jar [35] was
not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.303
!MESSAGE Missing required bundle org.eclipse.update.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.303
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.303
!MESSAGE Bundle update@plugins/org.eclipse.team.ui_3.1.1.jar [36] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.303
!MESSAGE Missing optionally required bundle org.eclipse.ui.ide_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.303
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.303
!MESSAGE Missing required bundle org.eclipse.compare_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.303
!MESSAGE Missing required bundle org.eclipse.ui.forms_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.304
!MESSAGE Bundle update@plugins/org.eclipse.ui.externaltools_3.1.1.jar [40] was
not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.304
!MESSAGE Missing optionally required bundle org.eclipse.ui.ide_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.304
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.304
!MESSAGE Missing required bundle org.eclipse.debug.ui_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.304
!MESSAGE Bundle update@plugins/org.eclipse.sdk_3.1.1/ [43] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.304
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.304
!MESSAGE Missing required bundle org.eclipse.help.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.304
!MESSAGE Missing required bundle org.eclipse.ui.cheatsheets_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.305
!MESSAGE Bundle update@plugins/org.eclipse.platform.doc.isv_3.1.1/ [46] was not
resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.305
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.305
!MESSAGE Bundle update@plugins/org.eclipse.ui.presentations.r21_3.1.0.jar [47]
was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.305
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.305
!MESSAGE Bundle update@plugins/org.eclipse.team.cvs.ui_3.1.1.jar [48] was not
resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.305
!MESSAGE Missing optionally required bundle org.eclipse.ui.ide_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.306
!MESSAGE Missing optionally required bundle org.eclipse.ui.views_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.306
!MESSAGE Missing optionally required bundle org.eclipse.jface.text_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.306
!MESSAGE Missing optionally required bundle
org.eclipse.ui.workbench.texteditor_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.306
!MESSAGE Missing optionally required bundle org.eclipse.ui.editors_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.306
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.306
!MESSAGE Missing required bundle org.eclipse.ui.console_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.306
!MESSAGE Missing required bundle org.eclipse.team.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.306
!MESSAGE Missing required bundle org.eclipse.compare_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.306
!MESSAGE Bundle update@plugins/org.eclipse.ui.intro_3.1.1.jar [50] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.307
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.307
!MESSAGE Missing required bundle org.eclipse.ui.forms_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.307
!MESSAGE Bundle update@plugins/org.eclipse.ui.ide_3.1.1.jar [53] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.307
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.307
!MESSAGE Missing required bundle org.eclipse.ui.views_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.307
!MESSAGE Missing required bundle org.eclipse.update.ui_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.307
!MESSAGE Bundle update@plugins/org.eclipse.search_3.1.1.jar [54] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.307
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.308
!MESSAGE Missing required bundle org.eclipse.ui.ide_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.308
!MESSAGE Missing required bundle org.eclipse.ui.workbench.texteditor_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.308
!MESSAGE Missing required bundle org.eclipse.jface.text_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.308
!MESSAGE Missing required bundle org.eclipse.ui.editors_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.308
!MESSAGE Bundle update@plugins/org.eclipse.team.cvs.ssh2_3.1.0/ [56] was not
resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.308
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.308
!MESSAGE Bundle update@plugins/org.eclipse.ui.forms_3.1.0.jar [60] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.308
!MESSAGE Missing required bundle org.eclipse.jface_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.309
!MESSAGE Missing optionally required bundle org.eclipse.ui_0.0.0.

!ENTRY org.eclipse.osgi 2006-02-04 11:07:02.309
!MESSAGE Bundle update@plugins/org.eclipse.ui.workbench.compatibility_3.1.0/
[64] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2006-02-04 11:07:02.309
!MESSAGE Missing host org.eclipse.ui.workbench_[3.0.0,4.0.0).
Comment 36 Stephen John Smoogen 2006-02-04 13:47:50 EST
went through by hand to see if it was a missing eclipse module

yum install eclipse-cdt
yum install eclipse-jdt
yum install eclipse-pde

This didnt fix things.. so I misdiagnosed how I fixed it before.. sorry. I
created a brand new user, and they have the exact same problem. They have no
CLASSPATH set
 

[root@raguel etc]# yum list | egrep 'jpp|java|jre|jdk|gcj' | grep install
ant.i386                                 1.6.2-3jpp_8fc         installed
ant-antlr.i386                           1.6.2-3jpp_8fc         installed
ant-apache-bcel.i386                     1.6.2-3jpp_8fc         installed
ant-apache-log4j.i386                    1.6.2-3jpp_8fc         installed
ant-apache-oro.i386                      1.6.2-3jpp_8fc         installed
ant-apache-regexp.i386                   1.6.2-3jpp_8fc         installed
ant-apache-resolver.i386                 1.6.2-3jpp_8fc         installed
ant-commons-logging.i386                 1.6.2-3jpp_8fc         installed
ant-javamail.i386                        1.6.2-3jpp_8fc         installed
ant-jdepend.i386                         1.6.2-3jpp_8fc         installed
ant-jmf.i386                             1.6.2-3jpp_8fc         installed
ant-jsch.i386                            1.6.2-3jpp_8fc         installed
ant-junit.i386                           1.6.2-3jpp_8fc         installed
ant-manual.i386                          1.6.2-3jpp_8fc         installed
ant-nodeps.i386                          1.6.2-3jpp_8fc         installed
ant-swing.i386                           1.6.2-3jpp_8fc         installed
ant-trax.i386                            1.6.2-3jpp_8fc         installed
antlr.noarch                             2.7.4-2jpp_1fc         installed
antlr-manual.noarch                      2.7.4-2jpp_1fc         installed
avalon-framework.noarch                  4.1.4-2jpp_5fc         installed
avalon-framework-manual.noarch           4.1.4-2jpp_5fc         installed
bcel.noarch                              5.1-1jpp_4fc           installed
classpathx-jaf.noarch                    1.0-2jpp_3fc           installed
classpathx-mail.noarch                   1.0-3jpp_1fc           installed
cryptix.noarch                           3.2.0-4jpp_1fc         installed
cryptix-asn1.noarch                      20011119-4jpp_1fc      installed
eclipse-ecj.i386                         1:3.1.1-1jpp_1fc.FC4.1 installed
eclipse-jdt.i386                         1:3.1.1-1jpp_1fc.FC4.1 installed
eclipse-jdt-devel.i386                   1:3.1.1-1jpp_1fc.FC4.1 installed
eclipse-pde.i386                         1:3.1.1-1jpp_1fc.FC4.1 installed
eclipse-pde-devel.i386                   1:3.1.1-1jpp_1fc.FC4.1 installed
eclipse-platform.i386                    1:3.1.1-1jpp_1fc.FC4.1 installed
eclipse-platform-devel.i386              1:3.1.1-1jpp_1fc.FC4.1 installed
eclipse-rcp.i386                         1:3.1.1-1jpp_1fc.FC4.1 installed
eclipse-rcp-devel.i386                   1:3.1.1-1jpp_1fc.FC4.1 installed
gcc-java.i386                            4.0.2-8.fc4            installed
gnu-crypto.noarch                        2.0.1-1jpp_5fc         installed
gnu-crypto-jce-jdk1.4.noarch             2.0.1-1jpp_5fc         installed
gnu-crypto-sasl-jdk1.4.noarch            2.0.1-1jpp_5fc         installed
gnu.getopt.noarch                        1.0.9-4jpp_1fc         installed
jakarta-commons-beanutils.i386           1.7.0-1jpp_4fc         installed
jakarta-commons-collections.i386         3.1-1jpp_4fc           installed
jakarta-commons-dbcp.noarch              1.2.1-3jpp_1fc         installed
jakarta-commons-digester.i386            1.6-2jpp_4fc           installed
jakarta-commons-el.i386                  1.0-2jpp_3fc           installed
jakarta-commons-fileupload.noarch        1:1.0-3jpp_1fc         installed
jakarta-commons-lang.noarch              2.0-2jpp_1fc           installed
jakarta-commons-launcher.noarch          0.9-3jpp_1fc           installed
jakarta-commons-logging.i386             1.0.4-2jpp_4fc         installed
jakarta-commons-modeler.i386             1.1-3jpp_4fc           installed
jakarta-commons-pool.noarch              1.2-2jpp_1fc           installed
jakarta-commons-validator.noarch         1.1.3-1jpp_1fc         installed
jakarta-taglibs-standard.noarch          1.1.1-4jpp_1fc         installed
java-1.4.2-gcj-compat.i386               1.4.2.0-40jpp_31rh.FC4 installed
java-1.4.2-gcj-compat-devel.i386         1.4.2.0-40jpp_31rh.FC4 installed
jdepend.noarch                           2.6-2jpp_3fc           installed
jdepend-demo.noarch                      2.6-2jpp_3fc           installed
jlex.noarch                              1.2.6-1jpp_2fc         installed
jpackage-utils.noarch                    1.6.3-1jpp_1rh         installed
jsch.i386                                0.1.18-1jpp_1fc        installed
junit.noarch                             3.8.1-3jpp_4fc         installed
junit-demo.noarch                        3.8.1-3jpp_4fc         installed
junit-manual.noarch                      3.8.1-3jpp_4fc         installed
jzlib.noarch                             1.0.5-2jpp_1fc         installed
ldapjdk.noarch                           4.17-1jpp_2fc          installed
libgcj.i386                              4.0.2-8.fc4            installed
libgcj-devel.i386                        4.0.2-8.fc4            installed
libgcj-src.i386                          4.0.2-8.fc4            installed
libswt3-gtk2.i386                        1:3.1.1-1jpp_1fc.FC4.1 installed
log4j.noarch                             1.2.8-7jpp_4fc         installed
log4j-manual.noarch                      1.2.8-7jpp_4fc         installed
lucene.i386                              1.4.3-1jpp_3fc         installed
lucene-demo.i386                         1.4.3-1jpp_3fc         installed
mx4j.i386                                1:2.1.0-1jpp_7fc       installed
mx4j-manual.i386                         1:2.1.0-1jpp_7fc       installed
oro.noarch                               2.0.8-1jpp_2fc         installed
puretls.noarch                           0.9-0.b4.1jpp_2fc      installed
regexp.i386                              1.3-1jpp_5fc           installed
struts11.i386                            1.1-1jpp_7fc           installed
struts11-manual.i386                     1.1-1jpp_7fc           installed
tomcat5.i386                             5.0.30-5jpp_6fc        installed
tomcat5-jasper.i386                      5.0.30-5jpp_6fc        installed
tomcat5-servlet-2.4-api.i386             5.0.30-5jpp_6fc        installed
xalan-j2.noarch                          2.6.0-2jpp_1fc         installed
xalan-j2-demo.noarch                     2.6.0-2jpp_1fc         installed
xalan-j2-manual.noarch                   2.6.0-2jpp_1fc         installed
xerces-j2.i386                           2.6.2-4jpp_5fc         installed
xerces-j2-demo.i386                      2.6.2-4jpp_5fc         installed
xerces-j2-scripts.i386                   2.6.2-4jpp_5fc         installed
xml-commons.i386                         1.0-0.b2.6jpp_12fc     installed
xml-commons-apis.i386                    1.0-0.b2.6jpp_12fc     installed
xml-commons-apis-manual.i386             1.0-0.b2.6jpp_12fc     installed
xml-commons-resolver.noarch              1.1-1jpp_4fc           installed
xml-commons-which.i386                   1.0-0.b2.6jpp_12fc     installed
Comment 37 Stephen John Smoogen 2006-02-04 20:03:05 EST
I think this is something to do with the prelink issue. I fresh installed an
older system and updated.. and eclipse worked. However after prelink ran.. it
gave the same problem
Comment 38 Igor Foox 2006-02-16 16:09:25 EST
Did you get this jar problem again after running prelink, or the problem with
the symlinks (prelink issue)?
Comment 39 Maxwell Bottiger 2006-03-06 16:03:38 EST
*** Bug 182101 has been marked as a duplicate of this bug. ***
Comment 40 Aaron Luchko 2006-03-06 21:27:33 EST
*** Bug 184009 has been marked as a duplicate of this bug. ***
Comment 41 Ben Konrath 2006-10-04 10:34:36 EDT
This bug is filed against FC4 which is no longer supported. Please re-test with
FC5 or FC6 and reopen the bug if the problem still exists. Thanks.

Note You need to log in before you can comment on or make changes to this bug.