Bug 177220 - Fatal server error: Caught signal 11. Server aborting
Summary: Fatal server error: Caught signal 11. Server aborting
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-07 21:13 UTC by Damian Wrobel
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 22:37:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xserver log (19.25 KB, text/plain)
2006-01-07 21:13 UTC, Damian Wrobel
no flags Details
rpm -qa output (28.24 KB, text/plain)
2006-01-07 21:14 UTC, Damian Wrobel
no flags Details
gdm output from the /var/log/messages (365 bytes, text/plain)
2006-01-07 21:24 UTC, Damian Wrobel
no flags Details
/usr/bin/X core dump (190.82 KB, application/octet-stream)
2006-01-09 08:12 UTC, Damian Wrobel
no flags Details
iomem - 2.6.15n - previously X server crashed on this kernel (998 bytes, text/plain)
2006-02-06 22:02 UTC, Damian Wrobel
no flags Details
ioports - 2.6.15n - previously X server crashed on this kernel (1.22 KB, text/plain)
2006-02-06 22:02 UTC, Damian Wrobel
no flags Details
iomem - 2.6.15-1.1909_FC5 (1016 bytes, text/plain)
2006-02-06 22:03 UTC, Damian Wrobel
no flags Details
ioports- 2.6.15-1.1909_FC5 (1.31 KB, text/plain)
2006-02-06 22:04 UTC, Damian Wrobel
no flags Details

Description Damian Wrobel 2006-01-07 21:13:27 UTC
Description of problem:

xorg segfaulting. This happens, when there is the following line in the log:
    (WW) ****INVALID IO ALLOCATION**** b: 0xe400 e: 0xe407 correcting

Version-Release number of selected component (if applicable):
It happens using the kernel-smp-2.6.15-1.1826.2.4_FC5, and the 2.6.15 vanilla
kernel, but works without any problems using the 2.6.15-rc5n vanilla kernel.

How reproducible:
always using mentioned above kernels.

Steps to Reproduce:
1. boot the system using the kernel-smp-2.6.15-1.1826.2.4_FC5 (level 5)

Comment 1 Damian Wrobel 2006-01-07 21:13:27 UTC
Created attachment 122909 [details]
xserver log

Comment 2 Damian Wrobel 2006-01-07 21:14:29 UTC
Created attachment 122910 [details]
rpm -qa output

Comment 3 Damian Wrobel 2006-01-07 21:17:36 UTC
lspci output the same as in bug #176724, attachment #122651 [details].


Comment 4 Damian Wrobel 2006-01-07 21:24:05 UTC
Created attachment 122911 [details]
gdm output from the /var/log/messages

Comment 5 Damian Wrobel 2006-01-09 08:12:59 UTC
Created attachment 122939 [details]
/usr/bin/X core dump

Comment 6 Mike A. Harris 2006-02-01 00:40:17 UTC
From the description above, it sounds like this might perhaps be a kernel
bug causing the problem.  Does the problem still occur with your system
fully updated to current Fedora development?


Davej:

Any idea what kernel changes might have caused such a problem to
appear?

Comment 7 Dave Jones 2006-02-03 20:05:39 UTC
no idea. if it is still a problem with the latest packages, the output of
/proc/iomem from both the good and bad kernels would be interesting to see.


Comment 8 Mike A. Harris 2006-02-04 13:00:25 UTC
Damian:

Could you provide the info from comment #7?

Comment 9 Mike A. Harris 2006-02-06 06:43:40 UTC
kernel-2.6.15-1.1909_FC5 is the current kernel in rawhide.  Please upgrade
to that kernel, and do a full update of all the latest Fedora devel packages.
Once you've updated, reboot into the new kernel and test X, then update the bug
report with your results.  Please do this as soon as you can, as the FC5test3
deadline is quickly approaching.

TIA

Comment 10 Damian Wrobel 2006-02-06 22:02:21 UTC
Created attachment 124282 [details]
iomem - 2.6.15n - previously X server crashed on this kernel

Comment 11 Damian Wrobel 2006-02-06 22:02:59 UTC
Created attachment 124283 [details]
ioports - 2.6.15n - previously X server crashed on this kernel

Comment 12 Damian Wrobel 2006-02-06 22:03:54 UTC
Created attachment 124285 [details]
iomem - 2.6.15-1.1909_FC5

Comment 13 Damian Wrobel 2006-02-06 22:04:37 UTC
Created attachment 124286 [details]
ioports- 2.6.15-1.1909_FC5

Comment 14 Damian Wrobel 2006-02-06 22:21:19 UTC
(In reply to comment #7)
> no idea. if it is still a problem with the latest packages,

Now using the latest devel packages and the 2.6.15-1.1909_FC5 kernel version the
problem is not reproducible anymore, even using the vanilla 2.6.15n kernel
(exactly the same binary files) on which the issue was previously reported.

(In reply to comment #6)
> From the description above, it sounds like this might perhaps be a kernel
> bug causing the problem.
IMHO, it didn't look like a kernel problem.


Comment 15 Mike A. Harris 2006-02-06 22:37:11 UTC
Ok, looks like something in rawhide fixes it for you, so we'll consider
it resolved for now.  If it recurs, just reopen the report and we'll
reinvestigate.  Thanks for testing.

Setting status to "RAWHIDE"


Note You need to log in before you can comment on or make changes to this bug.