Bug 177252 - No device nodes for cm4000_cs, cm4040_cs
No device nodes for cm4000_cs, cm4040_cs
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
MassClosed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-08 05:13 EST by Ville Skyttä
Modified: 2008-01-19 23:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-19 23:40:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Old /etc/pcmcia/smartcard for both cm4000 and cm4040 (950 bytes, text/plain)
2006-01-08 05:13 EST, Ville Skyttä
no flags Details
/etc/pcmcia/cardman_cs.conf for cm4000 (164 bytes, text/plain)
2006-01-08 05:15 EST, Ville Skyttä
no flags Details
/etc/pcmcia/cm4040_cs.conf for cm4040 (248 bytes, text/plain)
2006-01-08 05:16 EST, Ville Skyttä
no flags Details

  None (edit)
Description Ville Skyttä 2006-01-08 05:13:32 EST
Two new PCMCIA smart card reader drivers have been introduced in kernel 2.6.15,
cm4000_cs (OMNIKEY CardMan Mobile 4000) and cm4040_cs (OMNIKEY CardMan Mobile
4040).  The modules load ok at boot, but no device nodes are created.

I tried to figure out how to get the nodes created, but failed so far; no rules
I've tried have had any effect.

I'm attaching the /etc/pcmcia/smartcard script as well as the old vendor shipped
/etc/pcmcia/*.conf files which were used to create the devices in pcmcia-cs world.

In short, cm4040_cs devices should get /dev/cmxN nodes and cm4000_cs /dev/cmmN
(where N is the number of the card).

udevinfos about the cards:

CardMan 4040 (cm4040_cs):
  looking at class device '/sys/devices/pci0000:00/0000:00:1e.0/0000:02:00.1/1.0':
    KERNEL=="1.0"
    SUBSYSTEM=="unknown"
    SYSFS{card_id}=="0x0200"
    SYSFS{function}=="0x00"
    SYSFS{manf_id}=="0x0223"
   
SYSFS{modalias}=="pcmcia:m0223c0200f00fn00pfn00paE32CDD8Cpb8F23318Bpc00000000pd00000000"
    SYSFS{prod_id1}=="OMNIKEY"
    SYSFS{prod_id2}=="CardMan 4040"

CardMan 4000 (cm4000_cs):
  looking at class device '/sys/devices/pci0000:00/0000:00:1e.0/0000:02:00.1/1.0':
    KERNEL=="1.0"
    SUBSYSTEM=="unknown"
    SYSFS{card_id}=="0x0002"
    SYSFS{function}=="0x00"
    SYSFS{manf_id}=="0x0223"
   
SYSFS{modalias}=="pcmcia:m0223c0002f00fn00pfn00pa2FB368CApbA2BD8C39pc00000000pd00000000"
    SYSFS{prod_id1}=="CardMan"
    SYSFS{prod_id2}=="4000"
Comment 1 Ville Skyttä 2006-01-08 05:13:32 EST
Created attachment 122919 [details]
Old /etc/pcmcia/smartcard for both cm4000 and cm4040
Comment 2 Ville Skyttä 2006-01-08 05:15:11 EST
Created attachment 122920 [details]
/etc/pcmcia/cardman_cs.conf for cm4000

Note: before being included in the kernel, cm4000_cs was called cardman_cs, and
this file still reflects the old name.
Comment 3 Ville Skyttä 2006-01-08 05:16:08 EST
Created attachment 122921 [details]
/etc/pcmcia/cm4040_cs.conf for cm4040
Comment 4 Harald Hoyer 2006-02-15 07:09:39 EST
the modules should provide proper dev entries in sysfs
Comment 5 Ville Skyttä 2006-03-17 16:12:58 EST
FYI, I no longer have hardware to test this with, at least for now, so I'm fine
with closing the bug.
Comment 6 Dave Jones 2006-10-16 14:46:24 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 7 Jon Stanley 2008-01-19 23:40:27 EST
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.