Bug 177255 - less does not support unicode searches properly
less does not support unicode searches properly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: less (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Mike McLean
:
: 177254 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-08 06:12 EST by Need Real Name
Modified: 2013-07-02 19:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-10 07:29:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-01-08 06:12:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.6.5

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:

$ echo $LANG
de_AT.UTF-8
Comment 1 Need Real Name 2006-01-08 06:13:28 EST
bugzilla gave an internal server error, so here is the bug:

less behaves like it cannot understand multibyte characters in a search. It can
display them.

$ echo "Apache" > test-file
$ less test-file

Press / to start the search.
Type Apache, press enter.
It works.

Press / to start the search.
Type Ä
now press delete because it's the wrong character.
Type Apache, press enter.
No match.
Comment 2 Need Real Name 2006-01-08 15:29:46 EST
*** Bug 177254 has been marked as a duplicate of this bug. ***
Comment 3 Jindrich Novy 2006-01-09 05:05:17 EST
Confirmed that the less-382 behaves as described. The new less-394 now contains
much more enhanced support for UTF-8 and doesn't have this bug. I'll close this
as soon as I release FC updates for less-394.

P.S. The incoming messy emails from bugzilla made me really seriously thinking
that something's really wrong with less ;) From the first guess it was at least
50 new bugs!
Comment 4 Fedora Update System 2006-01-09 13:41:49 EST
From User-Agent: XML-RPC

less-394-1.fc4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Need Real Name 2006-01-09 14:03:15 EST
Aha! So that was what the upgrade was for! XML-RPC is in use! Does this mean we
get upstream-bugzilla bug tracking?

Anyway, thanks very much for the fix!
Comment 6 Need Real Name 2006-01-10 03:17:31 EST
WFM. Thanks.

Note You need to log in before you can comment on or make changes to this bug.