Bug 177291 - File descriptor leak in lib/gcov.exp
File descriptor leak in lib/gcov.exp
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gcc (Show other bugs)
4.3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
http://gcc.gnu.org/bugzilla/show_bug....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-08 23:18 EST by H.J. Lu
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 17:26:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A testcase (29.46 KB, application/octet-stream)
2006-01-08 23:22 EST, H.J. Lu
no flags Details
The kernel config file for 2.6.15 (46.94 KB, text/plain)
2006-01-09 11:59 EST, H.J. Lu
no flags Details

  None (edit)
Description H.J. Lu 2006-01-08 23:18:52 EST
Under both RHEL 4 U2 and RHEL3 U6 on IA64 and x86-64, kernel causes zombie
processes. It doesn't happen on IA32.
Comment 1 H.J. Lu 2006-01-08 23:22:01 EST
Created attachment 122934 [details]
A testcase

On IA32, I got

[hjl@gnu-10 gcc]$ make
srcdir=/export/home/hjl/bugs/kernel/gcc; runtest --tool gcc
WARNING: Couldn't find the global config file.
Test Run By hjl on Sun Jan  8 20:12:33 2006
Native configuration is i686-redhat-linux-gnu

		=== gcc tests ===

Schedule of variations:
    unix

Running target unix
Using /usr/share/dejagnu/baseboards/unix.exp as board description file for
target.
Using /usr/share/dejagnu/config/unix.exp as generic interface file for target.
Using ./config/default.exp as tool-and-target-specific interface file.
Running ./gcc.misc-tests/gcov.exp ...
FAIL: 211: expected branch percentages not found: 40
FAIL: gcc.misc-tests/gcov-4b-bad.c gcov: 0 failures in line counts, 1 in branch
percentages, 0 in return percentages
FAIL: 211: expected branch percentages not found: 40
FAIL: gcc.misc-tests/gcov-4b.c gcov: 0 failures in line counts, 1 in branch
percentages, 0 in return percentages
Running ./gcc.misc-tests/mg.exp ...

		=== gcc Summary ===

# of expected passes		77
# of unexpected failures	4
/usr/bin/gcc  version 3.4.4 20050721 (Red Hat 3.4.4-2)

make: *** [all] Error 1
[hjl@gnu-10 gcc]$

But on x86-64 and ia64, I got

[hjl@gnu-13 gcc]$ make
srcdir=/export/home/hjl/bugs/kernel/gcc; runtest --tool gcc
WARNING: Couldn't find the global config file.
Test Run By hjl on Sun Jan  8 20:19:28 2006
Native configuration is x86_64-redhat-linux-gnu

		=== gcc tests ===

Schedule of variations:
    unix

Running target unix
Using /usr/share/dejagnu/baseboards/unix.exp as board description file for
target.
Using /usr/share/dejagnu/config/unix.exp as generic interface file for target.
Using ./config/default.exp as tool-and-target-specific interface file.
Running ./gcc.misc-tests/gcov.exp ...
FAIL: 211: expected branch percentages not found: 40
FAIL: gcc.misc-tests/gcov-4b-bad.c gcov: 0 failures in line counts, 1 in branch
percentages, 0 in return percentages
FAIL: 211: expected branch percentages not found: 40
FAIL: gcc.misc-tests/gcov-4b.c gcov: 0 failures in line counts, 1 in branch
percentages, 0 in return percentages

It eventually timed out. ps showed

 6401 pts/9    S+     0:00 /bin/sh -c srcdir=/export/home/hjl/bugs/kernel/gcc;
r
 6402 pts/9    S+     0:00 /usr/bin/expect -- /usr/share/dejagnu/runtest.exp
--t
 6841 pts/9    Z+     0:00 [gcov-9.exe] <defunct>
 6842 pts/9    Z+     0:00 [cat] <defunct>
Comment 2 H.J. Lu 2006-01-09 11:54:19 EST
2.6.9-27.ELsmp in RHEL 4 U3 beta has the same problem.
Comment 3 H.J. Lu 2006-01-09 11:59:30 EST
Created attachment 122956 [details]
The kernel config file for 2.6.15

I tried 2.6.15. It has the same problem.
Comment 4 H.J. Lu 2006-01-09 14:57:35 EST
It turns out to be a gcc testsuite bug:

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=25728
Comment 5 H.J. Lu 2006-01-09 17:26:59 EST
I am closing it since it is a gcc bug.

Note You need to log in before you can comment on or make changes to this bug.