Bug 177306 - Forcedeth driver needs pci=routeirq (nVidia CK8S onboard NIC 10/100Mbps)
Forcedeth driver needs pci=routeirq (nVidia CK8S onboard NIC 10/100Mbps)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lalancette
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-09 09:07 EST by Milan Kerslager
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-21 04:14:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from the dmesg when pciroute parameter has been used (15.28 KB, text/plain)
2006-01-09 09:07 EST, Milan Kerslager
no flags Details
Dmesg output when no pci=routeirq parameter has been used and the NIC does not work (22.40 KB, text/plain)
2006-01-09 09:12 EST, Milan Kerslager
no flags Details

  None (edit)
Description Milan Kerslager 2006-01-09 09:07:48 EST
There is onboard NIC on the motherboard ASRock K8Upgrade-NF3. With the latest
kernel from FC4 all works, but on FC5test1 the LAN card does not work even
ethtool detect media and link properly (I tryed latest kernel from devel tree
too - 2.6.15-1.1826.2.5_FC5).

The kernel made an advice to use pci=routeirq so I did and all works Ok now.
Because the kernel asked to report this issue, here it is.

# lspci | grep Ether
00:05.0 Bridge: nVidia Corporation CK8S Ethernet Controller (rev a2)
# lspci -n | grep 00:05.0
00:05.0 0680: 10de:00df (rev a2)
Comment 1 Milan Kerslager 2006-01-09 09:07:49 EST
Created attachment 122945 [details]
Output from the dmesg when pciroute parameter has been used
Comment 2 Milan Kerslager 2006-01-09 09:12:41 EST
Created attachment 122946 [details]
Dmesg output when no pci=routeirq parameter has been used and the NIC does not work

Sorry for the confussion. The previous comment has pciroute instead of routeirq
in the comment.
Comment 3 Milan Kerslager 2006-01-09 21:37:21 EST
It seems that to make the NIC work, one have to reboot the system by "reboot"
command after the power on of the PC even pci=routeirq is in place all the time...
Comment 7 Chris Lalancette 2006-01-13 13:50:07 EST
Milan,
     Could you give the netdev kernels at
http://people.redhat.com/linville/kernels/fedora-netdev/ a shot?  It sounds like
it might be an ACPI problem, but it might be worthwhile to try out the newer
netdev kernels.

Thanks,
Chris
Comment 8 Milan Kerslager 2006-01-14 11:54:34 EST
Well. I picked up one of the three machines we have in the company with the same
motherboard. I'm not able to reproduce the problem with NIC card again as it is
different machine than I used to have at home when I was reporting this bug (I
opened it up to be sure). I'll try to switch the machines again but it seems
like ACPI bug you wrote about (older/newer BIOS as we did not bought them at the
same time so even same MB name they may differ).
Comment 9 Milan Kerslager 2006-01-21 16:21:34 EST
The installation kernel from FC5test2 is unable to detect the NIC even
pci=routeirq has been passed to the kernel (PXE install). After the reboot, NIC
works with no problem (with no special parameter).

The pure FC4 installation DVD is unable to detect the card too. Latest FC4
kernel seems to do not have the proble though.
Comment 10 Milan Kerslager 2006-03-21 04:14:54 EST
Final FC5 seems to not have the problem. I'll reopen if the issue arised again.

Note You need to log in before you can comment on or make changes to this bug.