Bug 177322 - mod_deflate doesn't compress documents to MSIE
mod_deflate doesn't compress documents to MSIE
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: httpd (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
http://issues.apache.org/bugzilla/sho...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-09 11:38 EST by Tarun Reddy
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2007-0445
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 14:42:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tarun Reddy 2006-01-09 11:38:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
Due to a bug in mod_setenvif.c, the documented way of enabling compression does not correctly compress non-text/html files to MSIE. Hence, all CSS, JS, and XML files are sent uncompressed.

See URL for Apache bug. This does not exhibit itself in RHES 4 since it is based off of a later version of Apache. However the fix is trivial to back port.

Version-Release number of selected component (if applicable):
httpd-2.0.46-56.ent

How reproducible:
Always

Steps to Reproduce:
1. Enable compression using setting at http://httpd.apache.org/docs/2.0/mod/mod_deflate.html
2. Connect from Microsoft Internet Explorer to any non text/html URL such as a CSS file or JS file.


Actual Results:  Uncompressed file is returned

Expected Results:  File should have been gzip'd compressed

Additional info:
Comment 7 Red Hat Bugzilla 2007-06-11 14:42:21 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0445.html

Note You need to log in before you can comment on or make changes to this bug.