Bug 177351 - PSGML signed by incorrect GPG key
PSGML signed by incorrect GPG key
Status: CLOSED DUPLICATE of bug 166030
Product: Fedora
Classification: Fedora
Component: psgml (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2006-01-09 17:49 EST by Dave Roberts
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-09 17:57:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dave Roberts 2006-01-09 17:49:52 EST
Description of problem:

It appears that the PSGML in the base repo of FC4 is not signed with a correct
Fedora Core GPG key. Trying to install via Yum causes Yum to generate an error
complaining about incorrect signature for the package.

Version-Release number of selected component (if applicable): 1.2.5-4

How reproducible:
Install FC4. Install psgml via yum.

Steps to Reproduce:
1. "sudo yum install psgml"
2. Enter "y" at the appropriate place.
3. Note the following output.
Actual results:
[dave@rio]$ sudo yum install psgml
Setting up Install Process
Setting up repositories
updates-released          100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
base                      100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package psgml.noarch 0:1.2.5-4 set to be updated
--> Running transaction check
--> Processing Dependency: sgml-common for package: psgml
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package sgml-common.noarch 0:0.6.3-17 set to be updated
--> Running transaction check

Dependencies Resolved

 Package                 Arch       Version          Repository        Size
 psgml                   noarch     1.2.5-4          base              203 k
Installing for dependencies:
 sgml-common             noarch     0.6.3-17         base               41 k

Transaction Summary
Install      2 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
Total download size: 243 k
Is this ok [y/N]: y
Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID db42a60e
public key not available for psgml-1.2.5-4.noarch.rpm
Retrieving GPG key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

The GPG key at file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora (0x4F2A6FD2)
is already installed but is not the correct key for this package.
Check that this is the correct key for the "Fedora Core 4 - i386 - Base" repository.

Expected results: PSGML should have installed.

Additional info:
Comment 1 Ignacio Vazquez-Abrams 2006-01-09 17:57:35 EST

*** This bug has been marked as a duplicate of 166030 ***

Note You need to log in before you can comment on or make changes to this bug.