Bug 177404 - USB mouse and keyboard on hp dc7600C
USB mouse and keyboard on hp dc7600C
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-10 08:23 EST by Michael Redinger
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: U3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-11 14:50:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2006-01-10 08:23:24 EST
Description of problem:

We are having problems with USB mice (and keyboards) on RHEL 4 (U2) using HP
dc7600C desktop computers:

- when using an USB mouse and keyboard, only the mouse works in the installer.
The keyboard does not work at all, even the leds for caps lock and scroll do not
work. (both text and graphical install)

- When using a PS/2 mouse instead (together with the USB keyboard), everything
works ok (installation and running RHEL).

- When I now reboot and change to the USB mouse again, the keyboard does not
work (kudzu starts and detects the change, but I cannot confirm it as the
keyboard does not work ...).

I noted that there was a kernel error message when booting with the USB mouse:

i8042.c: Can't read CTR while initializing i8042.

I reproduced this with several HP dc7600C computers, mice and keyboards.

I am having the same problem with FC4, but not with FC3.
Comment 1 Pete Zaitcev 2006-01-10 13:49:31 EST
20 against 1 bet it's BIOS. The proper course of action is to request a BIOS
update from HP. Sometimes it helps to find and disable a "USB Legacy" seting,
if BIOS setup provides it.

The U3 may help with usb-handoff option.

Please open a separate bug for FC4.
Comment 2 Michael Redinger 2006-01-11 12:17:43 EST
Ok, I tried the latest and gratest HP BIOS update from their website - same
problem with this (should have tried this earlier ...).

Then I downloaded the U3 beta. Without any options, the problem is still the same.
However, the usb-handoff option works fine for both install and running.

Thanks a lot!

Hm, what should I do with this now:
- ask HP for a fix? Never tried this before. Never had to do with their desktop
hardware (and support) before, but I suspect this would be rather difficult.
- open another bug for FC4?
  I suppose usb-handoff patch will be in FC5, too, right?
- As this is a hardware problem, this bug can be closed, right?
Comment 3 Pete Zaitcev 2006-01-11 14:44:06 EST
FC5 not only has usb-handoff, but also has it on by default.

FC4 with "yum update" should have the handoff code, and need the option to
turn it on.

Asking HP for a fix may be productive, but may be not. It's not undeard of
to get a fix... Dell fixed such problems for us, for example (bug 165749).
I cannot predict how responsive HP is going to be.

The bug should be closed, yes.
Comment 4 Michael Redinger 2006-01-11 14:50:40 EST
Thanks a lot! I am closing the bug. I will try to ask HP to fix this bug.

Note You need to log in before you can comment on or make changes to this bug.