This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 177405 - repoquery tracebacks with the --resolve option
repoquery tracebacks with the --resolve option
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 177406 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-10 08:23 EST by Sarantis Paskalis
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: yum-utils-0.6-3.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-13 09:13:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sarantis Paskalis 2006-01-10 08:23:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
repoquery crashes when supplied the --resolve option.  It works without it (it lists the individual capabilities).

# repoquery --requires --resolve gtk2
Traceback (most recent call last):
  File "/usr/bin/repoquery", line 640, in ?
    main(sys.argv)
  File "/usr/bin/repoquery", line 637, in main
    repoq.runQuery(regexs)
  File "/usr/bin/repoquery", line 409, in runQuery
    for p in self.doQuery(oper, prco): print p
  File "/usr/bin/repoquery", line 414, in doQuery
    return getattr(self, "fmt_%s" % method)(*args, **kw)
  File "/usr/bin/repoquery", line 444, in fmt_requires
    for res in self.whatprovides(req):
AttributeError: YumBaseQuery instance has no attribute 'whatprovides'


Version-Release number of selected component (if applicable):
yum-utils-0.3.1-1.fc4

How reproducible:
Always

Steps to Reproduce:
1. run repoquery --requires --resolve <packagename>
2. crash
3.
  

Additional info:

Fully updated FC-4 system.
rpm-4.4.1-22
yum-2.4.1-1.fc4
yum-utils-0.3.1-1.fc4
Comment 1 Sarantis Paskalis 2006-01-10 08:26:19 EST
*** Bug 177406 has been marked as a duplicate of this bug. ***
Comment 2 Sarantis Paskalis 2006-10-13 09:13:08 EDT
FWIW repoquery works fine with current FC-5 
rpm-4.4.2-15.2
yum-2.6.1-0.fc5
yum-utils-0.6-3.fc5

Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.