Bug 177438 - recent upgrade of net6 and obby packages break dependencies for gobby
Summary: recent upgrade of net6 and obby packages break dependencies for gobby
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gobby (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-10 17:54 UTC by John Guthrie
Modified: 2016-09-20 02:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-10 22:39:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Guthrie 2006-01-10 17:54:09 UTC
Description of problem:
When I run up2date -u, it runs just fine until it verifies the dependencies.  At
that time, I get the message:

There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
gobby  0.2.2-6.fc4                       requires libnet6-1.1.so.0
gobby  0.2.2-6.fc4                       requires libobby-0.2.so.0

As it turns out, it appears that the net6 package was recently upgraded to
version 1.2.2-1.fc4.  Also, the obby package was upgraded to 0.3.0-2.fc4.
So it looks like, the libraries that gobby needs are being pulled out from under
it.  I'm guessing that all this really requires is a recompiling and release
increment of the gobby packages.

Version-Release number of selected component (if applicable):
0.2.2-6.fc4

How reproducible:
Every time.

Steps to Reproduce:
1.Find a machine that has obby installed on it.
2.Run up2date -u
  
Actual results:
I got the error message indicated above, and up2date did nothing.

Expected results:
I should have received no error message, and up2date should have updated all of
the packages.

Additional info:

Comment 1 John Guthrie 2006-01-10 17:56:02 UTC
Bug 177233 refers to a similar problem with the obby package that seems to have
been fixed now.

Comment 2 Luke Macken 2006-01-10 22:39:35 UTC
I build obby-0.3.0-3 and gobby-0.3.0-2 for FC4.  They should hit the repos in
the near future.


Note You need to log in before you can comment on or make changes to this bug.