Bug 177440 - Installer crashed at gui.py line 1195 (handleRenderCallback)
Installer crashed at gui.py line 1195 (handleRenderCallback)
Status: CLOSED DUPLICATE of bug 173845
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-10 13:28 EST by Joe Neuhaus
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 15:50:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ouput of anaconda dump facility. (491.72 KB, text/plain)
2006-01-10 13:32 EST, Joe Neuhaus
no flags Details
Anaconda dump (196.24 KB, text/plain)
2006-01-13 17:25 EST, Robbie Barnett
no flags Details

  None (edit)
Description Joe Neuhaus 2006-01-10 13:28:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
See contents of anacdump.txt (attached).



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run setup on VmWare virtual machine (GSX Server 3.2.0 build-14497)
2.Choose IDE hard drives (SCSI drives are not recognized!)
3.Installer fails after choosing system components.
  

Actual Results:  See contents of anacdump.txt (attached).

Expected Results:  Installer should have completed installing components to virtual machine.

Additional info:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1195, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 245, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 924, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 145, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 216, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/backend.py", line 145, in doInstall
    backend.doInstall(intf, id, instPath)
  File "/usr/lib/anaconda/yuminstall.py", line 752, in doInstall
    self.ayum.run(self.instLog, cb, intf)
  File "/usr/lib/anaconda/yuminstall.py", line 363, in run
    self.populateTs(keepold=0)
  File "/usr/lib/anaconda/yuminstall.py", line 431, in populateTs
    for txmbr in self.tsInfo.getMembers():
  File "/usr/lib/anaconda/sortedtransaction.py", line 86, in getMembers
    returnlist.extend(self.pkgdict[key])
KeyError: ('enscript', 'i386', '0', '1.6.1', '31')

Full anacdump.txt file attached to this bug.
Comment 1 Joe Neuhaus 2006-01-10 13:32:23 EST
Created attachment 123005 [details]
Ouput of anaconda dump facility.
Comment 2 Robbie Barnett 2006-01-13 17:25:51 EST
Created attachment 123180 [details]
Anaconda dump


I have a similar problem when installing and/or upgrading from the Fedora
development tree. This part of the installation was running fine with same
media and system on previous days. Today I got this error.
Comment 3 Chris Lumens 2006-01-17 13:15:12 EST
Joe - What package selections did you make during installation?

Robbie - You are seeing a different problem that should be getting handled
better now.
Comment 4 Joe Neuhaus 2006-01-17 14:38:30 EST
Most likely it was the "server" package set, but I can't be 100% sure.
Comment 5 Chris Lumens 2006-01-17 15:50:52 EST

*** This bug has been marked as a duplicate of 173845 ***

Note You need to log in before you can comment on or make changes to this bug.