Bug 177513 - evolution sends incorrect password
evolution sends incorrect password
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-11 07:39 EST by Paul Nasrat
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-11 16:27:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 326385 None None None Never

  None (edit)
Description Paul Nasrat 2006-01-11 07:39:28 EST
Description of problem:

After I upgraded to latest rawhide after some time one of my imap accounts
stopped working.

Version-Release number of selected component (if applicable):

evolution-2.5.4-2.i386
evolution-data-server-1.5.4-2.i386

How reproducible:

Always with initial password

Steps to Reproduce:
1. Have imap account with & in password
2. Try to login
  
Actual results:

Recurring authentication failed dialogs

Expected results:

Login works
Additional info:

received: * OK pobox.surrey.redhat.com Cyrus IMAP4 v2.1.12 server ready
sending : B00000 CAPABILITY
received: * CAPABILITY IMAP4 IMAP4rev1 ACL QUOTA LITERAL+ MAILBOX-REFERRALS
NAMESPACE UIDPLUS ID NO_ATOMIC_RENAME UNSELECT CHILDREN MULTIAPPEND SORT
THREAD=ORDEREDSUBJECT THREAD=REFERENCES IDLE STARTTLS AUTH=PLAIN AUTH=LOGIN
X-NETSCAPE
received: B00000 OK Completed

sending : B00001 LOGIN xxx xxx
received: B00001 NO Login failed: authentication failure

testing manually with openssl s_client and manually confirmed password correct

Hacking eds to not mask login revealed incorrect string transmitted '&' was sent
as '&-'.  Changing password so no longer contained '&' enabled successful login
Comment 1 Paul Nasrat 2006-01-11 07:41:47 EST
Changing password to contain & again (eg Test123& causes authentication failures
again).
Comment 2 Dave Malcolm 2006-01-11 16:27:17 EST
Looks like a dup of this upstream bug:
http://bugzilla.gnome.org/show_bug.cgi?id=326385

(the bug is in e-d-s-1.5.4)

Note You need to log in before you can comment on or make changes to this bug.