Bug 177516 - CUPS can't find remote printers after kernel-2.6.14-1.1656_FC4 update
CUPS can't find remote printers after kernel-2.6.14-1.1656_FC4 update
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-11 08:15 EST by Matthew Saltzman
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.15-1.1831_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-22 11:22:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport (as reported by the .netdev kernel) (553.41 KB, application/octet-stream)
2006-03-01 22:20 EST, Matthew Saltzman
no flags Details

  None (edit)
Description Matthew Saltzman 2006-01-11 08:15:12 EST
Description of problem:
CUPS can't find remote printers after kernel-2.6.14-1.1656_FC4 update.

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1656_FC4

How reproducible:
Always

Steps to Reproduce:
1. Connect to network with CUPS printers shared from another machine.
2. Open system-config-printer or GNOME printer selection tool.
3. Observe list of printers
  
Actual results:
Remote shared printers are not displayed.

Expected results:
Remote shared printers should be displayed.

Additional info:
Problem also occurs with kernel-2.6.14-1.1656_FC4.netdev.7, does not occur with 
kernel-2.6.14-1.1653_FC4, does not occur with kernel-2.6.15-1.1823_FC4
(currently in updates-testing).
Comment 1 Matthew Saltzman 2006-02-01 19:48:28 EST
At this point, I can no longer reproduce this problem.  Not sure what the issue was.
Comment 2 Matthew Saltzman 2006-02-19 10:25:42 EST
This problem is back in kernel-2.6.15-1.1830_FC4.netdev.10, but not in
kernel-2.6.15-1.1831_FC4.
Comment 3 Matthew Saltzman 2006-02-24 18:59:47 EST
Well sure, it's true that it is CURRENTRELEASE, but I was trying to point out
that the netdev series still has the bug.  

There is not a kernel-2.6.15-1.1831_FC4.netdev or later yet, so it's hard to
know if the fix would carry over.  I haven't seen the problem in the mainstream
kernels since 2.6.15 appeared, but it appears in the 2.6.15 netdev kernels, so
it seems reasonable to conclude it has to do with one of the netdev patches.
Comment 4 John W. Linville 2006-03-01 16:46:20 EST
It seems unlikely that CUPS is specifically targeted for failure.  What other 
networking problems are you experiencing? 
 
What networking hardware are you using? 
 
Please attach the output of running "sysreport" as well...thanks! 
Comment 5 Matthew Saltzman 2006-03-01 22:20:34 EST
Created attachment 125513 [details]
sysreport (as reported by the .netdev kernel)
Comment 6 Matthew Saltzman 2006-03-01 22:27:41 EST
(In reply to comment #4)
> It seems unlikely that CUPS is specifically targeted for failure.  What other 
> networking problems are you experiencing? 

It does seem wierd, but that's the only problem I've detected.  If there are
others, they don't appear to interfere with normal operation.

>  
> What networking hardware are you using? 

This is a ThinkPad T41 with wireless ipw2200 and wired e1000.  The .netdev
kernel fails to detect the printers on either interface.  It appears as though
the production kernel can see the printers on either interface, but that's a bit
harder to test reliably.
>  
> Please attach the output of running "sysreport" as well...thanks! 

Done.

Comment 7 Matthew Saltzman 2006-03-08 08:24:57 EST
Update:  The problem still occurs with kernel-2.6.15-1.1833_FC4.netdev.12, but
not with the stock kernel-2.6.15-1.1833_FC4.
Comment 8 John W. Linville 2006-03-08 10:30:43 EST
Someone else reported a problem w/ ARP on those kernels.  I thought it sounded 
like it could be the same as this issue... 
 
I found this patch: 
 
http://people.redhat.com/linville/kernels/fc4/patches/jwltest-neigh-update.patch 
 
It was the only one that seemed to touch the neighbor code and was in the 
right timeframe.  I have added it to my "closer to stock" test kernels.  Would 
you mind trying those kernels and see if you have similar problems to the 
netdev kernels? 
 
   http://people.redhat.com/linville/kernels/fc4/ 
 
Please post the results here...thanks! 
Comment 9 Pekka Savola 2006-03-09 00:55:49 EST
My ARP problem (multiple IP subnets in the same physical media, where the
routing of IP subnets is asymmetrical) is indeed fixed (compared to netdev
kernels) in 2.6.15-1.1833_FC4.jwltest.33.  
Comment 10 Matthew Saltzman 2006-03-09 09:36:22 EST
CUPS remote printer detection works correctly with
kernel-2.6.15-1.1833_FC4.jwltest.33.
Comment 11 John W. Linville 2006-03-09 10:12:37 EST
Hmmm...well, then that wasn't it... :-(  I'll keep looking... 
Comment 12 Pekka Savola 2006-04-18 05:36:20 EDT
Update: the ARP problem I was having with netdev kernels doesn't seem to be
present in 2.6.16-1.2069_FC4.netdev.13.
Comment 13 Matthew Saltzman 2006-04-18 08:12:55 EDT
Remote printers are found in 2.6.16-1.2080.2.6_FC5.netdev.1 too.  What's changed?
Comment 14 John W. Linville 2006-04-19 09:45:42 EDT
Difficult to say...mostl likely it has to do w/ FC4/5 moving to a 2.6.16-based 
kernel.  I'll leave this open a bit longer "just in case"... 
Comment 15 Matthew Truch 2006-05-04 17:11:23 EDT
I recently noticed that I no longer get remote printers although I used to (a
couple weeks ago).  I don't know exactly which upgrade caused the problems, but
I currently experience them on FC5 running kernel 2.6.16-1.2107_FC5.  
Comment 16 John W. Linville 2006-05-05 10:45:05 EDT
Re: comment 15, I understand that there is a Xen-related patch causing such 
problems in FC5. 

Note You need to log in before you can comment on or make changes to this bug.