Bug 177521 - Unable to Print to Sharp AR-161 using JetDirect
Unable to Print to Sharp AR-161 using JetDirect
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cups (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2006-01-11 09:27 EST by M.R.Niranjan
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-02 08:08:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tcpdump of cups print (166.72 KB, application/octet-stream)
2006-01-20 01:52 EST, M.R.Niranjan
no flags Details

  None (edit)
Description M.R.Niranjan 2006-01-11 09:27:27 EST
Description of problem: On Redhat Enterprise Linux 4 ES While Configuring Cups
for Sharp Printer Model AR-161, There is an error 
"No IEEE 1284 match : {'model' : 'AR-160/200 series' 'Description': ", 'cmdset':
'PCL','manufacturer': 'SHARP' }

Please Report this message in bugzilla"


Version-Release number of selected component (if applicable):
Cups Version:
cups-1.1.22-0.rc1.9
cups-devel-1.1.22-0.rc1.9
bluez-utils-cups-2.10-2.1
libgnomecups-devel-0.1.12-5
gimp-print-cups-4.2.7-2

How reproducible: 


Steps to Reproduce:
1.system-config-printer 
2. Give printquename and select jetdirect type type IPAddress of the network printer
3. select Sharp Model 
  
Actual results:
"No IEEE 1284 match : {'model' : 'AR-160/200 series' 'Description': ", 'cmdset':
'PCL','manufacturer': 'SHARP' }

Expected results:

Sharp Printer installation using JetDirect should print jobs but unable to print


Additional info:
Comment 1 Tim Waugh 2006-01-11 09:38:10 EST
The message you see should not prevent you from printing; rather, it just means
that you need to automatically select the correct model from the list.

What happens when you try to print?
Comment 2 M.R.Niranjan 2006-01-11 23:50:15 EST
(In reply to comment #1)
> The message you see should not prevent you from printing; rather, it just means
> that you need to automatically select the correct model from the list.
> 
> What happens when you try to print?

It doesn't print at all but the message appers is job completed in cups Jobs
status. 
when we use the following command
netstat -an | grep 192.168.129.101:9100 
The connection appears Time_Wait, and closes after some time, but it does not print

Regards
Niranjan
Comment 3 Tim Waugh 2006-01-18 07:22:00 EST
What about if you try different drivers?  Go to System Settings->Printing from
the main Red Hat menu, select the queue and click edit.  Go to the 'Printer
driver' tab, and there is a drop-down menu under 'Available drivers'.  Select a
driver and then click OK and Apply, then try to print a test page.

If you try each of those in turn, do you get any output?
Comment 4 M.R.Niranjan 2006-01-18 07:27:15 EST
Hi Tim 

It worked if we select lpd , but not cups, and why does the Message comes 
""No IEEE 1284 match : {'model' : 'AR-160/200 series' 'Description': ", 'cmdset':
'PCL','manufacturer': 'SHARP' }

Please Report this message in bugzilla"
The above message comes when we select the sharp model. the sharp model is
AR-161 and the drives which are shown is also AR-161, but the above message comes. 

but we are able to print it now, with lpd option, selecting the same drives
which shows in selecting CUPS (IPP).

Regards
Niranjan
Comment 5 Tim Waugh 2006-01-18 08:03:25 EST
The message is harmless (see comment #2), and the necessary change has been made
for future releases.  The IEEE 1284 information can be used to automatically
select the correct model from the printer models list, but it is safe to ignore
the message and select the correct model yourself.

Thank you for trying the LPD method rather than the IPP method -- that certainly
seems to be where the problem lies.  It might be a problem with the printer's
IPP implementation, or it might be a problem with CUPS.

I would be very interested to see the network traffic when you try to print
using the IPP protocol (and it fails).  To capture this, you can use:

tcpdump -s 0 -U -w traffic.pcap host 192.168.1.1

with 192.168.1.1 replaced by the IP address or hostname of the printer.  Run
this command before you start to print a job, and afterwards press control-C. 
The traffic.pcap file is what I'd like to look at.

Also, please could you show me the output of 'rpm -q cups'?  I'd like to check
that you're using the most up-to-date package.  There has been at least one
update since cups-1.1.22-0.rc1.9.
Comment 6 M.R.Niranjan 2006-01-20 01:52:43 EST
Created attachment 123468 [details]
tcpdump of cups print
Comment 7 M.R.Niranjan 2006-01-20 02:04:51 EST
I have attached the tcpdump as requested by you. 

also , i would once again let you know the method we installed the printer ,
this method of installation did not give up print
is
system-settings->printing->printername->jetdirect->printerip:9100->model->sharp->AR-161

the print does not come. 
as you have asked the version of cups installed . 
The below are the cups packages installed on our Redhat Enterprise Linux 4 ES system

cups-1.1.22-0.rc1.9
cups-devel-1.1.22-0.rc1.9
bluez-utils-cups-2.10-2.1
libgnomecups-devel-0.1.12-5
gimp-print-cups-4.2.7-2
hal-cups-utils-0.5.2-8
cups-libs-1.1.22-0.rc1.9
libgnomecups-0.1.12-5

Regards
Niranjan
Comment 8 Tim Waugh 2006-01-23 07:56:01 EST
The captured traffic looks fine: the file is transferred without problem.  For
lack of any other indication it seems as though the problem lies with the
printer (or JetDirect module).

Please use RHN to update to the most recent cups errata package,
cups-1.1.22-0.rc1.9.8.  Does the problem still happen then?
Comment 9 Tim Waugh 2006-05-02 08:08:35 EDT
No feedback; closing.

Note You need to log in before you can comment on or make changes to this bug.