Bug 177555 - Sound System error message provides no information
Sound System error message provides no information
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-11 14:24 EST by james
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 12:49:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description james 2006-01-11 14:24:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
 Sound server informational message:
 Error while initializing the sound driver:
 device: default can't be opened for capture (Invalid argument)
 The sound server will continue, using the null output device.

There is no information there to allow debugging.  What "device" did the system try to open???  What "argument" was an invalid argument???  In what way did the system determine that an argument was invalid or that a device could not be opened???

This is a "slap in the face" error message.

Version-Release number of selected component (if applicable):
kdebase-3.5.0-0.1.fc4

How reproducible:
Always

Steps to Reproduce:
1.Control Center
2.Sound System
3.Hardware
4.Apply

or just boot the machine.
  

Actual Results:  error message

Expected Results:  sound

Additional info:

Running ALSA.  No other programs seem to have a problem with the sound.  "OSS" and "Enlightend Sound Daemon" will work, but not the ALSA or autodetect setting.
MIDI test sound will not work with any setting - all choices are ALSA devices.
Comment 1 james 2006-03-01 10:55:40 EST
Hmm - perhaps this bug should be summerized as "KDE does not work with ALSA." 
ALSA has been around for a while now, so it seems reasonable that KDE should be
upgraded to work with ALSA.
Comment 2 Ngo Than 2006-03-01 12:49:26 EST
strange, alsa works fine on FC4-UPDATE, i cannot reproduce this problem on
several test machines with FC4 here.

You should please update your system to FC4-update.

Note You need to log in before you can comment on or make changes to this bug.