Bug 177569 - perl-LDAP contains Net::LDAPS but perl-IO-SSL is not availible
perl-LDAP contains Net::LDAPS but perl-IO-SSL is not availible
Status: CLOSED DUPLICATE of bug 176387
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: perl-LDAP (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-11 16:08 EST by nathan r. hruby
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-12 16:41:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nathan r. hruby 2006-01-11 16:08:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
Hi,

The currently shipping perl-LDAP module contains the Net::LDAPS module for using SSL encrypted connections to LDAP servers.  Sadly, Net::LDAPS requires IO::Socket::SSL.pm  (which in turn depends on Net::SSLeay) whihc is not present in RHEL4.  

Please consider adding the pre-req's so Net::LDAPS can be useful or dropping the LDAPS.pm from perl-LDAP so there are not rpm conflicts for self-built LDAPS perl-module builds.

Thanks!

Version-Release number of selected component (if applicable):
perl-LDAP-0.31-5

How reproducible:
Always

Steps to Reproduce:
1. Install perl-LDAP with up2date
2. perl -MNet::LDAPS -e 'use Net::LDAPS; $foo = new Net::LDAPS()'
3.
  

Actual Results:  Dies with:
  Can't locate IO/Socket/SSL.pm in @INC 

Expected Results:  Creates a new Net::LDAPS object

Additional info:
Comment 1 Jason Vas Dias 2006-01-12 16:41:49 EST
Yes, this has been reported before ( bug 176387 ).

We ship a bare minimum set of perl module RPMs necessary to fulfil requirements.

The core Net::LDAP module does not require Net::LDAPS, IO::Socket::SSL, 
Authen::SASL or Net::SSLeay, and the Net::LDAP build mentions them as 
missing "optional modules", but still installs Net::LDAPS .

I think it is better not to modify the upstream Net::LDAP module, and let 
users discover the missing dependencies when they try to use Net::LDAPS,
than not to ship Net::LDAPS at all - they can then install the missing 
modules from CPAN.

I have submitted a request to Product Management to allow inclusion of
the missing  IO::Socket::SSL and Authen::SASL modules, which BTW are 
in Fedora Extras, in RHEL-4, to allow use of Net::LDAPS - if this 
enhancement request is granted, then we can ship these modules in RHEL-4-U4 . 


*** This bug has been marked as a duplicate of 176387 ***

Note You need to log in before you can comment on or make changes to this bug.