Bug 177647 - 'Generlal Ledger' crashes when using postgres
'Generlal Ledger' crashes when using postgres
Status: CLOSED DUPLICATE of bug 177646
Product: Fedora
Classification: Fedora
Component: gnucash (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-12 12:20 EST by javier wilson
Modified: 2014-03-16 22:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-13 12:32:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description javier wilson 2006-01-12 12:20:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When using postgresql backend and choosing 'Generlal Ledger' from the menu, I get and error message from guile:

Application "/usr/bin/guile" has crashes due to a fatal error (Segmentation fault)

then, it just exits.

Version-Release number of selected component (if applicable):
gnucash-backend-postgres-1.8.12-0.fc4

How reproducible:
Always

Steps to Reproduce:
1. open file using postgres backend
2. go to 'Tools'
3. choose 'General Ledger'
  

Actual Results:  Error: pgendGetResults: failed to get result to query:
        ERROR:  syntax error at or near ")" at character 315

Error: pgend_trans_commit_edit: send query failed:
        another command is already in progress

Error: pgendTransactionGetDeleted...(): send query failed:
        another command is already in progress

Error: pgendCopyTransactionToEngi...(): no such transaction in the database. This is unexpected ...

Error: xaccTransRollbackEdit: Rollback Failed.  Ouch!
Error: pgendGetResults: failed to get result to query:
        ERROR:  syntax error at or near ")" at character 315

Error: pgend_trans_commit_edit: send query failed:
        another command is already in progress

Error: pgendTransactionGetDeleted...(): send query failed:
        another command is already in progress

Error: pgendCopyTransactionToEngi...(): no such transaction in the database. This is unexpected ...

Error: xaccTransRollbackEdit: Rollback Failed.  Ouch!

Expected Results:  when using the normal (not postgresql) backend, a transaction window opens.

Additional info:
Comment 1 Bill Nottingham 2006-01-13 12:32:55 EST

*** This bug has been marked as a duplicate of 177646 ***

Note You need to log in before you can comment on or make changes to this bug.