Bug 177707 - When boot, system show "initialize_kbd: Keyboard failed self test" and "register_serial(): autoconfig failed"
When boot, system show "initialize_kbd: Keyboard failed self test" and "regi...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Maly
Brian Brock
:
: 177893 177989 177990 178151 178309 178990 181303 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-12 22:14 EST by leon
Modified: 2007-11-30 17:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 16:07:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description leon 2006-01-12 22:14:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Maxthon)

Description of problem:
When finished OS installation, ues "demsg" will show "initialize_kbd: Keyboard failed self test" and  "register_serial(): autoconfig failed.".
Just happen EL3 U3,U4,U5,U6,U7 beta x64;
EL3 U3,U4,U5,U6,U7 beta x32 have NOT this issue.

Version-Release number of selected component (if applicable):
EL3 U3,U4,U5,U6,U7 beta x64

How reproducible:
Always

Steps to Reproduce:
1.Install RHEL3 U3,U4,U5,U6,U7 beta x64
2.Enter OS
3.Use "demsg" and show "initialize_kbd: Keyboard failed self test" and  "register_serial(): autoconfig failed.".
  

Actual Results:  show "initialize_kbd: Keyboard failed self test" and  "register_serial(): autoconfig failed.".


Expected Results:  No such information.

Additional info:

Both RHEL 4 U1,U2 x86 and x64 have NOT this issue.
Comment 1 Miloslav Trmač 2006-01-16 06:47:48 EST
*** Bug 177893 has been marked as a duplicate of this bug. ***
Comment 2 Ernie Petrides 2006-01-16 16:40:52 EST
*** Bug 177893 has been marked as a duplicate of this bug. ***
Comment 3 Miloslav Trmač 2006-01-17 09:10:03 EST
*** Bug 177989 has been marked as a duplicate of this bug. ***
Comment 4 Miloslav Trmač 2006-01-17 09:10:24 EST
*** Bug 177990 has been marked as a duplicate of this bug. ***
Comment 5 Ernie Petrides 2006-01-17 16:32:28 EST
*** Bug 177989 has been marked as a duplicate of this bug. ***
Comment 6 Miloslav Trmač 2006-01-18 01:37:12 EST
*** Bug 178151 has been marked as a duplicate of this bug. ***
Comment 7 Ernie Petrides 2006-01-18 16:07:54 EST
*** Bug 178151 has been marked as a duplicate of this bug. ***
Comment 8 Ernie Petrides 2006-01-18 16:09:43 EST
*** Bug 177990 has been marked as a duplicate of this bug. ***
Comment 9 Miloslav Trmač 2006-01-19 05:47:43 EST
*** Bug 178309 has been marked as a duplicate of this bug. ***
Comment 11 Miloslav Trmač 2006-01-25 22:16:35 EST
*** Bug 178990 has been marked as a duplicate of this bug. ***
Comment 12 Miloslav Trmač 2006-02-13 10:27:49 EST
*** Bug 181303 has been marked as a duplicate of this bug. ***
Comment 13 Ernie Petrides 2006-02-15 15:05:29 EST
Reopening this bug after receiving apology from Leon.Lei@mic.com.tw
via e-mail.  For reference, the 7 dups are as follows:

    177893 177989 177990 178151 178309 178990 181303
Comment 14 Brian Maly 2006-03-15 16:09:42 EST
cant reproduce this issue. its certainly a hardware specific issue. what
hardware  exhibits this problem? can we get some info on Vendor, Make, Model,
Revision of this system?
Comment 15 grace 2006-03-27 04:51:32 EST
Hardware INFO as below:

System: Sun Microsystems
        Sun Fire( TM ) X2100
        Rev 50

Motherboard: Sun Microsystems
             Product: 2864
             Version: Rev 50
 
Processor: AMD Opteron (tm) Processor 180

Memory: Micron 1G DDR 400
Comment 16 Brian Maly 2006-04-11 10:21:33 EDT
some questions:

(1) does the keyboard still work even though you get an error message?
(2) what type of keyboard? USB or PS/2?

Comment 17 grace 2006-04-11 10:46:14 EDT
1.  Yes, the keyboard works fine despite the error message.
2.  Keyboard type: USB
             model: SUN Type 6
Comment 18 Brian Maly 2006-04-11 10:59:54 EDT
this looks like a problem similar to what is seen with some other (non Sun)
vendors systems that have removable (USB) keyboards. on these systems, the
keyboard is attached (via internal USB hub) after the keyboard init happens, so
an error is thrown even though the keyboard functions properly. there is a
workaround for this which may hopefully resolve this issue.

can you try booting the affected system with the "nokeyb" boot arg and see if it
helps?
Comment 19 grace 2006-04-12 06:43:18 EDT
I have tested with EL3U7, it works! This arg make the init program of keyboard
ignored during the boot up process? 
Is there a workaround for "register_serial(): autoconfig failed."?
And will these be fixed in EL3U8-64BIT?

Note You need to log in before you can comment on or make changes to this bug.