Bug 17775 - Install via FTP crash
Summary: Install via FTP crash
Status: CLOSED DUPLICATE of bug 17072
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-21 16:57 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-25 19:45:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-09-21 16:57:44 UTC
System:  486DX, 33MHz, 20MB RAM, 4GB HD, Etherlink III NIC, Cable Modem

When trying to install pinstripe via FTP (boot from bootnet.img) about 
halfway through the server installation (approximatly 250MB) the system 
suddenly pops up a dialog box telling me there was an error.  I re-tried 
two more times once at the same site and the other at a different site 
with the same results.

ERROR REPORTS:
-------------------------------------------------------

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 426, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/text.py", line 1022, in run
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/text.py", line 504, in 
__call__
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/todo.py", line 1522, in 
doInstall
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/todo.py", line 1265, in 
instCallback
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/urlinstall.py", line 47, 
in getFilename
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/log.py", line 23, in 
__call__
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
args: ('socket 
error', 'ftp://sunsite.utk.edu/pub/linux/redhat/redhat/beta/pinstripe/i386/
en/RedHat/base/hdlist', <socket.error instance at 8fb2f98>)
self: <log.LogFile instance at 81df980>
format: IOError %d occured getting %s: %s

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iurlinstall
UrlInstallMethod
p4
(dp5
S'baseUrl'
p6
S'ftp://sunsite.utk.edu/pub/linux/redhat/redhat/beta/pinstripe/i386/en'
sbsS'initlevel'
p7
I3
sS'progressWindow'
p8
(itext
ProgressWindow
(dp9
S'scale'
p10
(isnack
Scale
(dp11
S'w'

-----------------------------------------------------
Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 426, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/text.py", line 1022, in run
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/text.py", line 504, in 
__call__
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/todo.py", line 1522, in 
doInstall
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/todo.py", line 1265, in 
instCallback
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/urlinstall.py", line 47, 
in getFilename
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/log.py", line 23, in 
__call__
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
args: ('socket 
error', 'ftp://sunsite.utk.edu/pub/linux/redhat/redhat/beta/pinstripe/i386/
en/RedHat/base/hdlist', <socket.error instance at 8ddc7a8>)
self: <log.LogFile instance at 81df980>
format: IOError %d occured getting %s: %s

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iurlinstall
UrlInstallMethod
p4
(dp5
S'baseUrl'
p6
S'ftp://sunsite.utk.edu/pub/linux/redhat/redhat/beta/pinstripe/i386/en'
sbsS'initlevel'
p7
I3
sS'progressWindow'
p8
(itext
ProgressWindow
(dp9
S'scale'
p10
(isnack
Scale
(dp11
S'w'

-----------------------------------------------------
Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 426, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/text.py", line 1022, in run
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/text.py", line 504, in 
__call__
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/todo.py", line 1522, in 
doInstall
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/todo.py", line 1265, in 
instCallback
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/urlinstall.py", line 47, 
in getFilename
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/log.py", line 23, in 
__call__
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
args: ('socket 
error', 'ftp://ftp.valinux.com/pub/mirrors/redhat/redhat/beta/pinstripe/i38
6/en/RedHat/base/hdlist', <socket.error instance at 8e50618>)
self: <log.LogFile instance at 81df980>
format: IOError %d occured getting %s: %s

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iurlinstall
UrlInstallMethod
p4
(dp5
S'baseUrl'
p6
S'ftp://ftp.valinux.com/pub/mirrors/redhat/redhat/beta/pinstripe/i386/en'
sbsS'initlevel'
p7
I3
sS'progressWindow'
p8
(itext
ProgressWindow
(dp9
S'scale'
p10
(isnack
Scale
(dp11
S'w'

----------------------------------------------------
Hope this helps.
Tony

Comment 1 Michael Fulbright 2000-09-25 19:45:23 UTC

*** This bug has been marked as a duplicate of 17072 ***


Note You need to log in before you can comment on or make changes to this bug.