This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 177788 - Directory for pid-file not included in package
Directory for pid-file not included in package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks: 171491
  Show dependency treegraph
 
Reported: 2006-01-13 18:27 EST by Roy-Magne Mo
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-24 01:51:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to allow building under FC-3 (1.03 KB, patch)
2006-01-18 21:33 EST, Jason Tibbitts
no flags Details | Diff

  None (edit)
Description Roy-Magne Mo 2006-01-13 18:27:00 EST
Description of problem:
Directory for pid-file for spamassassin is not included in spamassassin package. 
/var/run/spamassassin/ should be included in spec-file

Version-Release number of selected component (if applicable):
spamassassin-3.1.0-3.fc5.1 (installed on FC4 server)

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Roy-Magne Mo 2006-01-13 18:30:30 EST
Also when stopping and removing the pid file, only the symbolic link are being
erased not the actual spec-file referenced in $SPAMD_PID in initscript.
Comment 2 Warren Togami 2006-01-14 02:35:02 EST
Good catch on the first problem, this will go to rawhide soon.

On the second problem, I suppose it wouldn't hurt to remove it, but are there
any instances where this would cause any problems as-is?
Comment 3 Roy-Magne Mo 2006-01-14 10:27:53 EST
(In reply to comment #2)
 > On the second problem, I suppose it wouldn't hurt to remove it, but are there
> any instances where this would cause any problems as-is?

No, seems like spamd is removing the pid file cleanly on shutdown.
Comment 4 Jason Tibbitts 2006-01-18 21:32:55 EST
Take this with a grain of salt because I'm building on FC-3, but the current
spamassassin package (3.1.0-4) needs to create
$RPM_BUILD_ROOT%{_localstatedir}/run/spamassassin in order to build for me.

I used the attached patch, which also removes a redundant creation of
$RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
Comment 5 Jason Tibbitts 2006-01-18 21:33:51 EST
Created attachment 123408 [details]
Patch to allow building under FC-3
Comment 6 Warren Togami 2006-01-24 01:51:38 EST
Thanks, done in FC5.

Note You need to log in before you can comment on or make changes to this bug.