Bug 177826 - pirut - backtrace while looking through installed ruby packages
pirut - backtrace while looking through installed ruby packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-14 19:30 EST by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-24 18:14:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-01-14 19:30:57 EST
Description of problem:

I got the following in circumstances described in summary:

Component: Software Manager
Summary: TB085d19a0 pirut:228:__filter_package_list:AttributeError: 'NoneType'
object has no attribute 'repoid'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 228, in __filter_package_list
    elif self._showPackageType == SHOW_AVAIL and po.repoid == "installed":
AttributeError: 'NoneType' object has no attribute 'repoid'

Local variables in innermost frame:
i: <GtkTreeIter at 0x316c420>
model: <gtk.ListStore object (GtkListStore) at 0x2aaaaf36d690>
po: None
self: <__main__.PackageManager object at 0x2aaaae4de110>

and the second time slightly different:

Component: Software Manager
Summary: TB7d2bce87 pirut:225:__filter_package_list:AttributeError: 'NoneType'
object has no attribute 'repoid'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 225, in __filter_package_list
    elif self._showPackageType == SHOW_INSTALLED and not \
AttributeError: 'NoneType' object has no attribute 'repoid'

Local variables in innermost frame:
i: <GtkTreeIter at 0x5396e80>
model: <gtk.ListStore object (GtkListStore) at 0x2aaaaf0de230>
po: None
self: <__main__.PackageManager object at 0x2aaaae4de110>


Version-Release number of selected component (if applicable):
pirut-0.9.2-1

How reproducible:
It seems to be reproducible although it is hard to tell.  On a DSL line
every operation takes _ages_ making this tool rather unusable.

Steps to Reproduce:
1. in "Development" browse (I think) pick up "Ruby"
2. click on "List" icon and get backtrace
3. sometime before "Installed packages" was selected for listing
Comment 1 Jeremy Katz 2006-01-18 12:22:19 EST
At least something of a fix in rawhide, although I can't reproduce
Comment 2 Michal Jaegermann 2006-01-19 16:56:43 EST
That fix does not seem to fix very much.  This is what I got with
pirut-0.9.4-1 although this time it took three or four switches between
"Listing" and "Browsing".  No idea if "Ruby" packages are not purely accidental
here.  The program immediately exits on this error.

Component: Software Manager
Summary: TB473cb537 pirut:226:__filter_package_list:AttributeError: 'NoneType'
object has no attribute 'repoid'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 226, in __filter_package_list
    elif self._showPackageType == SHOW_INSTALLED and not \
AttributeError: 'NoneType' object has no attribute 'repoid'

Local variables in innermost frame:
i: <GtkTreeIter at 0x32dd120>
model: <gtk.ListStore object (GtkListStore) at 0x2aaaafd74550>
po: None
self: <__main__.PackageManager object at 0x2aaaaf11aa50>

It is clear from addresses above that this is with 64-bits.  Relevant?
Comment 3 Jeremy Katz 2006-01-24 18:14:43 EST
The fix wasn't in until 0.9.5 -- 0.9.4 just added pup.  I was traveling last
week and so didn't get it built unil I got back
Comment 4 Michal Jaegermann 2006-01-25 00:25:13 EST
Yes, with 0.9.5 I did not manage to repeat the problem.

Not that I know what pirut really should be doing.  Its present interface
is for me quite incomprehensible.

Note You need to log in before you can comment on or make changes to this bug.