Bug 177844 - "internal server error" on new bug submission containing non-ascii characters
"internal server error" on new bug submission containing non-ascii characters
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
high Severity high (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
: 178519 230337 230338 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-15 08:16 EST by Need Real Name
Modified: 2007-02-28 08:59 EST (History)
0 users

See Also:
Fixed In Version: 2.18-rh
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-28 08:58:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-01-15 08:16:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.6.5

Description of problem:
While trying to submit bug 177843, I get an internal server error.
The bug is still created, but the bug comments are not there.

Appending the bug comments to the bug works.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Look at bug 177843.
2. Try to create a new bug which is exactly the same as this.
3. Internal server error.

Additional info:
Comment 1 Need Real Name 2006-01-17 05:13:21 EST
I have no idea if this is needs a severity of "security".
Comment 2 Need Real Name 2006-01-21 05:31:27 EST
*** Bug 178519 has been marked as a duplicate of this bug. ***
Comment 3 Need Real Name 2006-01-21 05:31:40 EST
Bugzilla isn't utf-8 aware!

If the summary contains e.g. an umlaut, the bug is not entered.
If the bug comments contain an umlaut, the bug is entered, but without the bug
comments.

(Is a bug entry not one transaction?)
Comment 4 David Lawrence 2006-02-01 11:35:50 EST
Was the bug entered with the guided or expert interface?
Comment 5 Need Real Name 2006-02-04 15:06:00 EST
Guided.
Comment 6 Need Real Name 2006-03-07 04:52:30 EST
This is still broken. Should this be marked as security severity?
It seems like the application has not been written to handle non-ascii characters.
Comment 7 Need Real Name 2006-10-26 16:22:55 EDT
Fedora People blogs are complaining a lot about bug reporters setting the status
of bugs to NEEDINFO, with the NEEDINFO being from the package maintainer.

Please can I have some feedback on this?
Comment 8 Need Real Name 2007-02-28 08:58:42 EST
> Fedora People blogs are complaining a lot about bug reporters setting the status
> of bugs to NEEDINFO, with the NEEDINFO being from the package maintainer.
> 
> Please can I have some feedback on this?

So much for open source. There was nothing "open" about this bug at all.
Complete silence from the assignee.

Well, it works for summary lines now. See bug 230337.
Also for descriptions. See bug 230338.
Comment 9 Need Real Name 2007-02-28 08:59:06 EST
*** Bug 230338 has been marked as a duplicate of this bug. ***
Comment 10 Need Real Name 2007-02-28 08:59:37 EST
*** Bug 230337 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.