Bug 17785 - Printing to remote (Samba) printer does not work.
Printing to remote (Samba) printer does not work.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: lpr (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-22 02:04 EDT by Harry Hart
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-25 22:29:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harry Hart 2000-09-22 02:04:21 EDT
Configure remote samba printer, using printtool.
Try printing ASCII test page; fails with error message 
"Error printing test page to queue lp0"
"Error reason: lpr: connect: Connection refused"
"jobs queued, but cannot start daemon."

I've tried restarting lpd, manually killing & restarting lpd, uninstalling
and replacing lpr rpm.
I've checked /etc/services to be sure that TCP port 515 is defined for
spooler.
I've also tried LPRng (from Rawhide).  It fails with a different message
about failed connection.
I've observed this problem when printing to a remote LPD printer, as well.
I'm using this version:   lpr-0.50-4

Any suggestions ?
Thanks - Harry
Comment 1 Harry Hart 2000-09-25 22:29:28 EDT
More info about problem.  Even when printer is connected directly to parallel port, printtool tests don't work (fail with same message), except for "print 
directly to port" test.  When I telnet localhost 515 (or telnet from another machine), I get the following message, followed by an immediate 
disconnection:
"lpd: lp: Malformed from address"
Using lpc, even when 'ps ax' shows two lpd daemons running, 'lpc status' says "no daemon present".  
Basically, the only printing I can do is the printtool direct-to-port test.
However, Windows machines can connect via Samba and print with no problem.
Comment 2 Preston Brown 2000-09-26 16:49:48 EDT
also, maybe you haven't set up /etc/hosts.lpd...in this file you need to list
the remote hosts line-by-line that are allowed to use the printer.
Comment 3 m.bizzarri 2000-10-01 10:37:27 EDT
Ok, I don't know if this is the case, but it seems to me a bug I've seen a
number of time in the
lpd daemon. The problem seems to be in files to be printed in the print queue,
and in a remote printer (lpd) which is not reachable at the time the local lpd
is started. You can verify this to
be the problem since you should see two ldp running. Also, you can't print on
any printer.

To solve this, the solution is to stop the daemon printer, remove all the files
from the spool area (lprm -Pprinter -), and then starts the daemon printer
again.

Note You need to log in before you can comment on or make changes to this bug.