Bug 177854 - 2.6.15-1.1854_FC5 breaks named, 1853 is fine
2.6.15-1.1854_FC5 breaks named, 1853 is fine
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
:
Depends On: 177853
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-15 12:53 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 11:26:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-01-15 12:53:41 EST
+++ This bug was initially created as a clone of Bug #177853 +++
It is created blocked on the kernel bug, such that bug searches in bind will
find it, avoiding dupes.

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060103
Fedora/1.5-4 Firefox/1.5

Description of problem:
After today's rawhide update, that modified only the kernel and replaced pup
with pirut, named would no longer respond to local queries.  Rebooting into
yesterday's kernel fixed it.  I still haven't figured out what it was in the
kernel that broke it, but it's pretty clear that it is the kernel that did it.

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1854_FC5

How reproducible:
Always

Steps to Reproduce:
1.Boot a box with a local caching name server into 2.6.15-1.1854_FC5
2.Issue queries to the local named
3.Reboot into 2.6.15-1.1853_FC5
4.Issue the same queries

Actual Results:  2. times out, 4 works.

Expected Results:  2. should work

Additional info:
Comment 1 Jason Vas Dias 2006-01-15 18:17:45 EST
2.6.15-1.1854_FC5 changed the format of the /proc/net/if_inet6 file, which
makes named fail to parse this file, and refuse to listen on any interface
(see comment appended to bug 177853).

If this change is going to be permanent, I'll fix named's scanf format to 
read the new format - but as the change adds no information, and serves only
to break existing software, I'm guessing (and hoping) that it will be backed
out - awaiting response from kernel maintainers.
Comment 2 Jason Vas Dias 2006-01-16 18:32:53 EST
As it may take some time for the kernel patch which fixes the /proc/net/if_inet6
format to make it upstream and into our kernel, I've submitted a temporary fix to
bind to allow named to operate with the either the old or new /proc/net/if_inet6
format, with bind-9.3.2-2, which is in rawhide-20060116 .
Comment 3 Alexandre Oliva 2006-02-07 11:26:58 EST
The bind patch fixed it, thanks.

Note You need to log in before you can comment on or make changes to this bug.